Can't save presets

**SketchUp version :Pro 2017 17.2.2555 64 bit
Skatter version (Skatter dialog > Options > About) : 1.4.1
**OS :*Win 7 Ultimate 64bit
**Description of the issue : I can’t save my custom presets. Tried to use SU as admin, no changes.
Are you able to reproduce the issue every time? (If yes, how?) : yes, every time now. I had no problem in the past.
I downgraded skatter till 1.3.0 but it’s the same. Perhaps a SU 2017 incompatibility?
Error in Ruby Console? (Window > Ruby Console) :

Error: #<NoMethodError: undefined method []' for nil:NilClass> C:/ProgramData/SketchUp/SketchUp 2017/SketchUp/Plugins/jbb_skatter/rb/library.rb:49:insave_lib_item’
C:/ProgramData/SketchUp/SketchUp 2017/SketchUp/Plugins/jbb_skatter/rb/dialog.rb:403:in block in start_dialog' C:/ProgramData/SketchUp/SketchUp 2017/SketchUp/Plugins/jbb_skatter/rb/dialog.rb:20:incall’
C:/ProgramData/SketchUp/SketchUp 2017/SketchUp/Plugins/jbb_skatter/rb/dialog.rb:20:in block in add_bridge_callback' SketchUp:1:incall’

There is nothing between “#” and “C:/…”?

Are you trying to use a thumbnail?

Okay. I’ve understood.
I was using Windows Screen Capture tool and it saves files as *.JPG instead of *.jpg.
Then I was trying to use the *.JPG files as thumbnails and Skatter wasn’t able to interpret them as jpg files (I guess).

I realized that when I checked for any difference in file types with ACDsee (an image browser).
I manually changed the JPG to jpg and voilà, now skatter CAN save the preset as usual.

Thanks for your hint, Thomas :wink:

Ok thanks for the report, I’ll see if I can fix it.

I haven’t tried but I guess the same problematic will happen with PNG instead of png.
Just a CASE problem. Haven’t tested Jpg either, or jpeg.