Editing Materials for Thea & Enscape

Hello,

I am trying Transmutr to create proxies for Thea and Enscape. I manged to create some test proxies, but I can’t find a way to edit the materials.

For Enscape I opened the full geometry skp and modified the materials there, and when I use enscape directly in the full geometry file I can see the changes fine. But those changes do not appear when I import the proxy file in another sketchup file.

And how can I modify the materials for Thea?

Thanks.

This is really strange. If the old materials are not in the proxy file anymore, there is no way for SketchUp to get them when importing in another file.
Are you 100% sure you saved the file after changing the materials?

For Thea, you need a .mod.thea file.
By default, Transmutr creates the Thea proxy as an .xml file (and several .mesh.thea files in a subfolder). But when you start Transmutr from within SketchUp and Thea v2.1 (and above) is installed and active, Transmutr will ask Thea to convert the exported .xml file to a .mod.thea file.
Then you can edit the materials in this proxy .mod.thea file like any other .mod.thea file that was exported directly from Thea itself.
You can learn more at the bottom of this page: http://kb.thearender.com/thea-for-sketchup-v20/creating-proxies-from-fbx-and-thea-models/

Are you 100% sure you saved the file after changing the materials?

Yes. I opened the _fullGeomerty.skp file and edited a material (I just changed the material type from “Default” to “Clearcoat”) and then saved the file. If I render with Enscape within the _fullGeomerty file, then the material change shows fine.

Then I create a new Sketchup file and do a File > Import, and I select the low poly skp file created by Trunsmutr (not the _fullGeomerty one). When I render with Enscape it renders without showing the change of the material to “Clearcoat”.

If I use Enscape’s own Enscape Objects > Linked Model, and I select the _fullGeomerty file to create a proxy, then it shows fine.

Am I doing something wrong?

Could you send me the files (the source file as well as the skp files) to [email protected] ?

The files are very big and they aren’t mine, so I am not sure if I can email them.

It seems to work in other examples I tried, so maybe I did something wrong with that one.

Now I am also having some issue with Thea, but the same issue happens when creating a proxy directly from Thea so this doesn’t seem to be Transmutr issue (https://thearender.com/forum/viewtopic.php?f=171&t=26488)

By the way, until when will you have the discount on Transmutr? I still have a few more days on my trial, but I don’t want to miss the better price.

Ok, please let me know if it happens again on a file that you can share.

The discount will run until Tuesday December 3rd.