Absolute accuracy when importing, possible or not?

Hi all, may I ask if it is possible to retain the accuracy in 3d model and avoid decimals when importing files to SketchUp with Transmutr? I am asking as directly importing .dae files does not have the same problem.
Changing units in SketchUp does appear to work visually, however, after exporting to dwg format, the floating point number will still appear in the CAD software.

Hi @kii

I’m not sure I see the exact issue in the screenshot you attached.
Do you mean that purple points are not accurately positionned?

Hi merwan

Yes I do mean the purple point are not accurately positioned.

As shown in the screenshot, a column of 1000mmx1000mm width is measured as 1000.0005mm. Which, in turns means when generating 2d dwg file, it will have the same decimals inaccuracy.

The same issue is not present if you import the dae file directly using sketchup’s native importer.

Below are the dae, skp generated by transmutr, dwg generated by sketchup for your reference, thanks.


@kii Thanks for the clarification.

I added this issue in our bug tracker and we’ll do some tests.

Do you apply any kind of transformation in Transmutr (scale, simplification…)?

Thanks for looking into it!

I usually change the units conversion to meter, scale multiplier at 100% (default), mesh simplification 0% (default), the other settings also keep at defaults.

My use case is to use Transmutr to import models (in dae/obj) with instancing/ material data intact. The models are architectural and usually from blender (which could be the reason for inaccuracy, but somehow the native importer works ok for simple objects).

1 Like