Am I missing a trick?

We’ve recently got a tree library from evermotion, the models came in a variety of formats but only FBX and OBJ are relevant here.
A typical tree is around 50mb in either of the formats but after I convert it via Transmutr I’m getting 300, 400, 500mb Sketchup models even with 70% poly reduction.
A couple of the more complex trees are coming in at over 1000mb skp files !!

I’m happy to send one of the trees via a dm for you to test but obviously I can’t post a link to it publicly here.

We use Enscape and I’ve successfully converted and used plant/flower libraries from VisPark with the Transmutr Enscape proxy and can place 100’s of then in a model without any problems but there evermotion trees are killing me with even just 1 on a model.

This is due to the SketchUp file format. The way it stores information produces files much bigger than other file fomats (like FBX and OBJ).
I’m afraid there is no solution to this, we have no control over the SketchUp file format.

Thanks for the reply, that’s what I feared.
Looks like we’ll be asking Evermotion for a refund and our hunt for small/immature/sapling trees will continue.

PS this is how the previously mentioned Vispark flowers and bushes look in Enscape after being Transmuted from OBJ’s.


What rendering engine are you using?
Can’t you use proxies?

Enscape, and yes they are proxys generated wirth your wonderful Transmutr

Oh! So even as proxies, the Evermotion models are too heavy?

Also, keep in mind that when you export as proxy from Transmutr, the proxy file is always full geometry, the simplification slider has no effect on it.
If you want the proxy to be simplified, do not export it as proxy but as a regular .skp file, then with Enscape import that .skp file as a proxy from Extensions > Enscape > Enscape Objects > Linked Model. The caveat is that it will only appear as a box.

The proxy’s generated by T are fine and are suitably small but once I get more than one tree in a model then the Enscape either doesn’t complete the initial startup when it substitutes the proxy’s for full or it takes so long I kill it.

So when creating a transmutr proxy, might I ask what the options “simplify geometry” or “face skipping” are actually there for, when the resulting proxy files still contain all the geometry? isn’t the meaning of a proxy to get a simplified work version, that won’t overload sketchup for instance?

I just noticed this with a simple shrub. the proxy looks simplified in sketchup but once you turn on hidden geomtery, all of it actually is still there, thus not really making the project any lighter?

It’s one of the main reasons i bought transmutr, to keep my sketchup files manageable.

Hi Merlin,

I replied to your email. Please send me your file because I can’t reproduce the issue.