[BETA] 1.2.0-beta.3

Version 1.2.0-beta.3

The blank window on MacOS should be fixed. Please tell us if you still have this issue with Beta 3.

Please report any issue in the Bug Reports section . Thanks for your help!

Download Windows: http://files.getskatter.com/transmutr_setup_1.2.0-beta.3.exe
Download MacOS: http://files.getskatter.com/transmutr_setup_1.2.0-beta.3.pkg

Bug fixes

  • Fixed the “white window” bug that occurred when starting Transmutr on MacOS.
  • Fixed a crash that occurred when running several instances of Transmutr simultaneously.
  • Fixed the connection to Megascans failing silently when the communication port is already in use.
  • Fixed textures with power-of-two dimensions being upside down in the preview.

@Eric_Sargeant @DBJ @jql @AhmedMady @oxer @nrh1981 @HardyV @corey_diru @ThePixelArtist @dimitrisiosifidis @Miki @stefanoc @valerostudiogmail-co

1 Like

Hi Thomas, version installed as single user (option change installation location) and the issue persists. I changed the port but tha same issue.
Blank window and port issues appear again.

SU2017 & macOS 10.13.6

I don’t know if this can be help, I opened Transmutr via Terminal and it appears this message:

iMac-de-Oxer:~ Oxer$ /Users/Oxer/Applications/Transmutr.app/Contents/MacOS/Transmutr ; exit;

16:12:45.331 › Starting GUI...

GVA error: Not detecting IGPU in IORegistry!

GVA error: Not detecting valid offline codec!

GVA info: Successfully connected to the Intel plugin, offline Gen6

16:12:45.376 › Loading the page

dyld: lazy symbol binding failed: Symbol not found: __ZNKSt3__14__fs10filesystem4path16__root_directoryEv

Referenced from: /Users/Oxer/Applications/Transmutr.app/Contents/Resources/app.asar.unpacked/_webpack/Transmutr.node (which was built for Mac OS X 10.15)

Expected in: /usr/lib/libc++.1.dylib

dyld: Symbol not found: __ZNKSt3__14__fs10filesystem4path16__root_directoryEv

Referenced from: /Users/Oxer/Applications/Transmutr.app/Contents/Resources/app.asar.unpacked/_webpack/Transmutr.node (which was built for Mac OS X 10.15)

Expected in: /usr/lib/libc++.1.dylib

Same message error…

Dear Thomas,
This version does not work

This is very useful, thank you!

What is your MacOS version?


I get a bit farther with this beta, but still no success converting files. Launching the Transmutr app on Mac now shows the main window instead of a blank window. However, clicking the Browse button to start the conversion process, and then selecting a file, just returns me to the main Transmutr window, rather than opening the file I selected. I’ve tried various FBX and OBJ files. The files are in a folder on my Desktop. This is running the latest Mac OS X 10.15.2.


I have the same issue too

Hi Thomas,
(+ Happy New Year)
Unfortunately the same issues persist as before. Unlike some of our other posters, i am getting nothing at all coming up when launching the application independently of SU other than the drop down options at the top of the screen. (Not even a white screen) All menus are greyed out.
In SU i get the same message as user StafanOC.
SketchUp 2017 Pro w/ Max OSX 10.13.4 (High Sierra)
(edit For further reference I installed the new beta over the old version without first deleting the old one, not sure if this makes a difference)

We are making progress on the two reported issues:

  1. It turns out we’ve been building Transmutr for Catalina only. We didn’t notice, because we don’t have older versions of MacOS to test on. We are trying to build for older versions, but there are dependencies that our code relies on that require Catalina. We are looking into finding alternatives.

  2. Regarding the issue where Transmutr does seem to work but goes back to the main screen when you load a file, we think we have found a fix.

We did not upgrade to Cataline or Mojave as any version of SketchUp prior to 2018 (and other associated CAD software) does not work on these platforms. Upgrading the entire office to the current version was prohibitively expensive at the time though something that we have accepted we will have to do at some point.

Just successfully transmuted an .fbx with textures… works well so far. Win7