Hi Thomas, First of all, congratulations for the tool, I see it with great success. I’m having problems importing objects in sketchUp 2020, closes with BugSplat error.

Does it happen for all assets?
Only marketplace assets, or also local .skp files?

Are you on Windows or MacOS?

Free assets, I am on Windows 10.

Do you import as Default, Proxy, High-Poly?

Hi, Thomas I used Sketchup 2021 and it worked perfectly

i cant import assets that have more than one asset on their list, for example i can import the glasses of water since its one object, but when i try to do the same with the dishes and wine glasses of the free dining models the option is grayed out and i cant pick any object to import.

Do you mean assets that have more than one file?

sorry i think i did not explain well the problem, when you can choose from one of several models on the restaurant tableware by humano everything is grayed out and i cant download any of them.

Thanks for the details and screenshot.
This should only happen when the asset has been downloaded: the extension finds the JSON .bazaar file (what we call the "manifest). But the .skp files referenced by the manifest do not exist, or at least not next to the .bazaar manifest file.

Can you check in C:\Users\USERNAME\Documents\3DBazaar\Downloads\Restaurant-Tableware_l48f6web1lj_0_default (or elsewhere if you changed the download location), if the .skp files exist?

its very odd, they do exist and they are in the default location but they are not being recognized by the extension, they are like stuck, downloaded but not usable, perhaps deleting them can fix it but its a weird bug.
This does not happen with new assets, i downloaded the free books and espresso cup and it worked ok, its just with objects downloaded with previous versions of the plugin.

I think that’s the reason why it doesn’t work!

Sorry we didn’t specify this in the release notes but the format of the packages has changed since the previous beta version. If you delete the old packages and download them again then it should work better.

1 Like

cool! im deleting the old files and trying again then! Thanks merwan! btw i tried to buy the mangos bowl ( transaction went allrignt i think ) but when i try to download it i get this error:

That’s unexpected, sorry for the inconvenience :confused:

Does it work if you download your file from the website? (LINK TO THE MODEL)

This was a server-side issue, that is now fixed. Sorry for time lost!

1 Like

Thanks @Thomas and @merwan ! Yes i could donwload it fine with no problem on the website. I´m glad it´s now fixed! don´t worry about it guys that´s what we are here for :+1: