Can't install Skatter Mac Catalina / SketchUp 2019

Haven’t been able to install Skatter on SketchUp 2019. I am using Mac Catalina. I have tried twice but it does not show up under Extensions. I’ve looked in Extension Manager and it does not show up there, either. Any suggestions? Thanks!

Hi @Jdcamc

When you install Transmutr on Mac, it can be located in two locations:

  • $HOME/Library/Application Support/SketchUp 2019/SketchUp/Plugins/ (if you selected“install for me only”)
  • /Library/Application Support/SketchUp 2019/SketchUp/Plugins/ (if you selected “install for all users”)

Can you check and report back if there are Transmutr files in thoses two locations?


No, it is not there but a scatter folder does appear under the /Library/Application Support/.


J. David Conley

[email protected]

That’s quite unusual.

  • When you install Transmutr, does the installer shows any error message or everything seems OK?
  • Do you have other SketchUp versions installed? (if yes, does Transmutr work with them?)

There weren’t any errors during the installation. Also, I have it installed on my laptop and it works fine there. However, there isn’t a folder labeled Tramsmutr there. I’ve enclosed a screenshot of my laptop SketchUp plugins folder.

Hi @Jdcamc,

Sorry I was confused. I thought this issue was about our other product, Transmutr, because you posted in the “Transmutr” section of the forum.

(I’m moving your post to the appropriate section)

Ok now that I understand that this is about Skatter, please try this:

  • Go to /Library/Application Support/SketchUp 2019/SketchUp/Plugins/
    • Check if the jbb_skatter.rb and jbb_skatter folder are located here
    • If yes, delete them both
  • Try to re-install Skatter

Please note that the folder to check is in the /Library/Application Support at the top-level of your computer. The screenshot that you sent actually shows the /users/johnconley/Library/Application Support that is under your user account (Skatter does not get installed here).

I’m not sure what you mean by “top-level of your computer.” All I know is in Finder, click on Go while holding the Option key down which will display Library and then go to the appropriate folder from there. How do I get to the “top-level?”


J. David Conley

[email protected]

OK, I found the correct path and those folders are not there but Skatter is listed under the Application Support folder. I have re-installed Skatter twice but it still is not showing up. Do I need to remove the Skatter folder under Applications Support?


J. David Conley

[email protected]

Yes, unfortunately, Apple makes accessing those files unnecessarily complicated. They are hidden by default.

One way to access those files from Finder is to use the Shift + Command + G shortcut to show a “Go to the folder” window and then you can type the folder name (or just / to go to the top-level).

You can ignore the Skatter folder in /Library/Application Support (it only contains Skatter’s library of models).

However, if there’s nothing related to Skatter in /Library/Application Support/SketchUp 2019/SketchUp/Plugins, this means that the installer failed to copy the Skatter files here and this explains why SketchUp cannot not load the extension.

Usually we don’t have such issues with installing Skatter so let’s hope we find a solution.
We can try those other approaches:

Check other SketchUp versions

I noticed on your screenshot that you also use SketchUp 2018 on your laptop, do you also use it on your other computer?

If yes, does Skatter work with SketchUp 2018 (or any other installer SketchUp version)?

Check the installation log

Another thing that we can try is to look at your computer’s install log.

Please retry to install Skatter and then immediately check the /var/log/install.log file and send us the lines at the bottom of the file, those that match the current time.

(It’s a long file that MacOS writes to when something gets installed and if errors occurred, they should have been written to that file).


Do you use any kind of antivirus software? Sometimes they misinterpret software installation as malware and mess things up.

If you use such software, could you try to disable it temporarily while you install Skatter to check if it installs correctly?

OK, well, I was able to “cheat” the installation. Since I had Skatter installed on my laptop, I just copied the folders onto my desktop and it is working fine. If I remember correctly, when you first install Skatter, it will ask you where you want to install it. Obviously, I selected to wrong path so that’s probably why it wasn’t showing up in SketchUp. And when I tried to re-install it, it remembered the path I selected the first time and didn’t give me the option to select another path, so that’s probably why the other installations didn’t work either. But it is working now! Thanks for your help!

Well that’s one way to fix it :slight_smile:
Good to know that works now.