Error loading some Xfrog assets (TIF files?)

I’ve been getting errors like the example shown below when loading certain XFROG OBJ & FBX assets. It seems to relate to the TIF image files.

My workaround has been to save the TIF maps to PNG & remove the originals so that the model will load and then assign the PNGs.

I’ll send an example model to [email protected]

1 Like

Hi @samuelnorth

Thanks for the bug report. I can reproduce the same errors.

So I spent the morning investigating what goes wrong with the model that you sent to us and it seems like it has some anomalies that prevents Transmutr from loading it properly. I’m not sure how these files were produced but there’s a few unconventional things in there.

I sent you fixed files that should import OK now.

Here are the technical details, if needed.

  • Some materials have unsupported attributes (the unusual “map_opacity” field in the MTL file). This issue is not critical and doesn’t interrupt the import but it means that even if it worked, materials would not be imported perfectly.

  • The TIF images that cames with the model cause trouble when Transmutr tries to convert them internally to PNG. I could not determine the cause of the issue unfortunately but there’s something wrong with those images. Your solution of directly providing PNG files worked though (after editing the MTL file with the appropriate names).

  • The OBJ file contains invalid geometry. That’s the critical issue that interrupts the import. If we look inside the file, some faces are defined on several lines using a special \ symbol to break the description of the face into multiple lines (that’s rare but it happens in some models, depending on the exporter used) but spaces are missing

For instance, in your file, it looks like:

f  57317/1415/102316 57318/1416/102317 57314/426/102309\

Because there’s no space, the face data is read as:

f  57317/1415/102316 57318/1416/102317 57314/426/10230957313/425/102308

(two numbers are wrongly merged together)

Instead, it should look like this (no line breaks):

f  57317/1415/102316 57318/1416/102317 57314/426/102309 57313/425/102308

Or like this (line break, but there’s a space before):

f  57317/1415/102316 57318/1416/102317 57314/426/102309 \
1 Like

Hi @merwan thanks for the info and file.

Glad to hear it’s not me, i’m not really sure I understand the technical problems though.

The main issue for me is that quite a number of the Xfrog assets i’ve tried are the same and I have the full library (~3000) but only convert models occasionally when needed.

I’ll try the 3DS version when i get chance and have asked if i can get the FBX version too so fingers crossed - i’ll report back.

Can i show them your findings if they ask what the issue is?

1 Like

We’re actually in contact with Xfrog to help them bring their assets to SketchUp so hopefully this will make things easier for you in the near future.


1 Like