Error message. Deleted surfaces, Sketchup freeze.


#1

52 34 56 SketchUp version: 2019
Skatter version: 1.4.7.
OS : MacOS Mojave 10.14.4
Description of the issue : Big urban planning project can’t open due to error message. Have waited hours
Are you able to reproduce the issue every time? Yes. By opening the file.
Error in Ruby Console?: Child 3g8mRoMFzaH9zKTZAHAZPt not found
I have screen shots of the error messages.

Is it possible to delete Skatter objects in a file with Skatter unistalled?


#2

I replied to your email.


#3

Thanks for the file.

There are two things going in your file:

1. Deleted surfaces
This error message appears because a group that was used as a Host surface in the setup called “Skatter 3” has either been deleted, or moved in the hierarchy (nested in another group/component, or its parent was exploded).
As a result, Skatter is not able to find the surface and warns you about it, as it can’t generate the setup anymore.

2. Freeze
Actually it’s not freezing, it just takes a very long time to compute the setup called “Skatter 10”. On my computer it takes 50 minutes. It looks like it’s trying to compute the boundaries of an area that has way too much geometry.

Here is a workaround to both issues:

  1. Open SketchUp (don’t open the file yet)
  2. Go to the Extensions manager and disable Skatter
  3. Restart SketchUp (this is important to disable Skatter)
  4. Open your file. It should open normally, Skatter being disabled.
  5. Go the Window menu and open the Ruby Console.
  6. Paste the following code in the console, and press enter (this is one line, make sure to copy/paste it properly):
    Sketchup.active_model.attribute_dictionaries.each{|d| Sketchup.active_model.set_attribute(d.name, "enabled", false) if d.name.match(/jbb_skatter_.{8}-.{4}-.{4}-.{4}-.{12}/) }
    This will disable all the Skatter “Render only” setups.
  7. Go to the Extensions manager and enable Skatter
  8. Open Skatter’s Render List and enable the setups one by one. I suggest you don’t enable “Skatter 10”, but instead delete it and create it again, otherwise it will take 50 minutes to compute.

#4

Hi Thomas
Thank you so much for your response and help. Unfortunately it doesn’t work. As soon as I enable Skatter again (after copying and pasting your code) the Skatter error message appears and the model “freezes”.

Best regards,

Hans


#5

Is “Do not compute disabled setups at startup” checked in Skatter’s options?

Here is a line of code that will delete “Skatter 10”. Use it in step 6.
Sketchup.active_model.attribute_dictionaries.each{|d| Sketchup.active_model.attribute_dictionaries.delete(d.name) if d.name == "jbb_skatter_a77c8726-1697-47cb-a854-0545a3beda99" }


#6

I will check and get back to you.

Thank you so much for your quick responses and help!

Br

Hans


#7

I’ve now managed to delete all Skatter scenes and will now start fresh. Thank you again for your helpful support!!

Best regards,

Hans