I'm getting an error while testing Transmutr beta on MacOS

I’m a MacOS user, Today I started testing beta version of Transmutr on my iMac, but sadly after I installed the extension I got an error, I’ve tried to remove it and reinstall it but every time I get the same error.

I was wondering if anyone else getting the same error or it’s only me, anyway I’ve attached to this topic a screenshot of the error that I’m getting, and I’ve mentioned bellow some details about the MacOS version that I’m using as well as the SketchUp version.

MacOS Catalina Version 10.15.2
SketchUp Pro 2019 Version 19.3.252

I’m hopping to get some help, as I’m so excited to start using Transmutr on macOS.

1 Like

Same here. Tried on both Catalina and Mojave. Also tried manually moving the transmutr.rb to the directory path that it says is missing. Error message goes away but no toolbars, etc show up for Transmutr.

1 Like

Same on OSX 10.14.6
SU Pro 19.3.252

Hi @AhmedMady @Eric_Sargeant and @DBJ. Thanks for the bug report.

Can you confirm that none of those files exist on your computers?

  • /Users/YOUR USERNAME/Library/Application Support/Transmutr/transmutr.json
  • /Library/Application Support/Transmutr/transmutr.json
1 Like

The one on top NO
The one on bottom YES

1 Like

We found a solution to this bug. We’ll release a new version of Transmutr soon.
Thanks for your help!

1 Like

In the meantime, you should be able to make it work by installing Transmutr in the user directory:

  • In the “Installation type” screen of the installer, click “Change install location…”
  • Select “Install for me only”
1 Like

That works but then the port issue appears:

SketchUp cannot connect to Transmutr. Try changing the Port in Extensions > Transmutr > Settings. If the issue persists, please contact [email protected]

Ok this installed as you suggested but still says “invalid signature” and I can’t find the plug-in…

No more error though.