Invisible plant with render only

SketchUp version :2017
Skatter version (Skatter dialog > Options > About) : 1.4.2
OS :Windows 7
Description of the issue : I have a plant that renders fine by itself or if skattered in SU scene but its invisible when using render only. I’m using Thea render and have tried with all Theas different render engines.
I have looked at the model and textures but couldn’t find anything odd. Ive also tried exploding every subgroup/component without luck. Any help would be appreciated.

Are you able to reproduce the issue every time? (If yes, how?) : Yes, even in different SU models.
Error in Ruby Console? (Window > Ruby Console) : none.Invisible with render only.skp (591.0 KB)

Renaming the component fixes the issue.
This is purely a Thea issue, so you should contact Altair to tell them about this.

Thank you.

I must say however that I was experiencing this behavior with Vray on my PC and Mac both. Latest versions of everything. I didn’t have too many items so I just choose to show everything and then it would render.

Bug on Thea side indeed. Fixed “internally” so far.

1 Like

Please see this : [Workaround] V-ray 3.6 does not show skatter objects.

Oh thank you!