SketchUp 2019
Skatter version 1.4.7
Mac OS High Sierra 10.13.6
Cannot put skatter on layers
Are you able to reproduce the issue every time? - Yes it always happens
Error in Ruby Console? :
Generate bounding boxes & transformations : 0.00033 s
Scatter objects : 0.000391 s
Total number of points : 32
View redraw : 0.016147 s
Total : 0.029497 s
------ End ------

I am not able to put any skattered objects on a layer. After I create the objects and (re)generate, I click on the “Render List” tab, select the new skatter object, and then select the layer I want it on. However, I can turn that layer on and off but the skatter objects are still showing even though I have turned off the layer I just put it on. For whatever reason it is not being linked to that layer. I’ve tried many times but nothing works. Please help - I need this for a project I’m working on. If I close the Skatter dialog box, I loss the skatter objects. I can’t get anything to work.

Does this happen in a brand new file?

If not, can you send me the problematic file?

Yes, it happens in a new file. Once I skatter the grass, I am not able to click out of the work area to deselect the skatter command so I can then select the existing skattered grass to place on a layer. But, after experimenting, I’ve found out that if I create the layer first and select that as my default layer and then invoke the skatter command, the skattered object will be on that layer. Kind of the long way around but the end results are the same.

I’m sorry, I’m not sure I understand what you mean.
Could you record a short video showing the issue? You can use this: