Map Finding


#1

I’m Transmutring an OBJ file from CGAxis and I noticed in there .mtl file for the OBJ they have absolute paths setup so know of the maps are getting located. Is it possible to have Transmutr look in the same folder or a folder called Maps in the same location as the file your are importing when it cannot locate maps?

Transmutr didn’t even give me a warning that the maps could not be found, it just created diffuse colors based on the .mtl I assume


#2

Hi @valerostudiogmail-co,

That’s actually something that we implemented a few days ago already :wink:

It will be available in the next release (1.0.2).


#3

I am trying this on an OBJ from CGAxis. All of the maps in the mtl file are calling for an absolute location e.g. map_Kd D:\CGAXIS\Volume43\maps\cgaxis_models_43_01_03.jpg

I have all the maps in the folder called ‘Maps’ but Transmutr just imports the OBJ with no maps at all. Every material comes in gray. If I remove the path in the MTL it works. Is it possible to have Transmutr ignore the pathing on MTL files if the file is not found?


#4

Transmutr should already do that.
Can you send us the files? (obj, mtl, and maps)


#5

Thanks for the files.

What version are you using? It works fine for me in v1.0.3
There are only two maps missing: cgaxis_models_43_02_01.jpg and cgaxis_models_43_02_01_bump.jpg, because they are missing in the Maps folder.

If it still doesn’t work with v1.0.3, can you try to copy the maps in the same folder as the .mtl (instead of a subfolder)? And tell me if it works that way


#6

V1.0.3 - Tried moving the maps directly into

the same location and I still get the same result


#7

Funny thing is that I do not even get the message that it cannot find the textures. If I try to open the file on my home machine, it works. Both are Windows 10 machines.


#8

Can you do it again, then close Transmutr, then send me your log file?
You can find it by going to the Options, then click on “Open log folder”