Maxwell Render??

I’ve recently bought Skatter v2, having previously used Scatter v1 with Maxwell Render.
To my disappointment Maxwell native support has been dropped in Skatter 2 and so far I could not get the proxies and ‘render only’ mode to work as in the previous version, which unfortunately makes this plugin useless for me.
Can you please confirm if/why Maxwell isn’t supported anymore? And in that case is there an alternative workflow to use Skatter with Maxwell (or other render engines besides Vray or Thea)?

Even if I don’t use proxies, creating a new ‘scattered object’ within sketchup and exporting to Maxwell v5 in ‘render only mode’ simply doesn’t work, only the host object shows up in the render. Not the results I expected with Skatter v2!
Also Skatter proxies in 3dBazaar are not compatible with Maxwell :roll_eyes:

Hi @HugoC

I can confirm that we have not dropped support for Maxwell Render.

It’s either a bug in Skatter or the latest versions of Maxwell has dropped support for Skatter (it’s actually the renderers that have to connect to Skatter to render the generated instances, and not the other way around).

We’ll do some tests and get back to you. It might take a few days though, as we’re waiting for a Maxwell license to investigate your issue.

1 Like

By the way: does Maxwell still works ok for you with Skatter 1?

We chose to offer proxies for V-Ray/Enscape/Thea because of a survey we ran a few months ago, asking our users which renderers they used.

It showed that less than 1% of our users used Maxwell (actually there was a single user that did among 918 users) so unfortunately it didn’t make the cut as the amount of work it would require to integrate far exceeds the number of users.

1 Like

Thanks for looking into this merwan.
Maxwel Render v5 was working fine with the previous version of Scatter.
The only way I can get Skatter2 to work is by generating the full objects geometry in model (impossible task) or creating mxs proxies in Maxwell which defeats the purpose of using Skatter.
Skatter2 ‘render only’ mode doesn’t seem to work with Maxwell at all? Loading proxies via 3DBazaar doesn’t work either for the reasons you mentioned. I understand you developed Skatter2 to a great extent but it’s a shame that you removed a feature that was already in Skatter1.
Maxwell may not be the most popular rendering engine at the moment but in my experience produces the most accurate/unbiased results, I’m reluctant to switch just for compatibility issues. Would be great if you could fix this with an update soon (or let me know if there’s a workaround).


Thanks for those details @HugoC

As mentionned previously, this is most likely a bug. We did not intend to drop support for Maxwell :slight_smile:

We’ll investigate this asap and keep you updated about the progress.

1 Like

Sounds good, hope you can fix that bug fairly soon. Finding a solution for the proxies is easy, not so easy as importing straight from 3DBazaar (or Skatter1 previous menu), but I’m able to export mxs files and use those as proxy objects. The main problem is that ‘render only’ mode is simply not working with Maxwell as it seems to work with other rendering engines so it would be great if you could fix that.

@HugoC We’re using Maxwell’s trial version to do some tests. I am unable to make it work even with Skatter 1.

Here’s what I do with Skatter 1:

  • Launch Skatter
  • Pick a host
  • Pick an object
  • Toggle “Render only”
  • Generate
  • Start an interactive render (“Maxwell fire”)

This does not render the generated instances. If I turn off “Render only”, generate again and click “Re-export the scene” in Maxwell then it works of course.

Do you do things differently?
Which version of Skatter, Maxwell and SketchUp are you using?

1 Like

I used the exact same procedure with Skatter1 in the past only difference is that I usually export to Maxwell Render instead of Fire within Sketchup.
I’m now using Skatter2, Maxwell5 and Sketchup2020.

Can you confirm that it still works on your side with Skatter 1?
This will help us understand if something changed in Skatter or in Maxwell.

I was running trial version of Skatter1 before so can’t confirm that sorry. Can’t remember if I used the ‘render only’ mode in Skatter1 but proxies from the Skatter library worked fine for sure.
Does Skatter2 ‘render only’ mode work on all other main rendering engines?

@HugoC So we did additional tests and searched through Skatter’s archives and… It seems that Maxwell has never supported Render Only mode!

If you search for videos and tutorials that describe working with Maxwell+Skatter, they often mention that it only works in In Model mode. I think that there was some plan to support Maxwell in the past but it never panned out. Sorry for the confusion, we thought it worked too :sweat_smile:

We’ll still contact the Maxwell developers to see if they are interested in supporting Skatter.

Yes, it works with the renderers listed on this page: V-Ray 5, Enscape, Thea, Octane, Indigo, Shaderlight, IRender nXt, Twilight Pro, Raylectron, and Kerkythea.

1 Like