Problem with vray

Hi there

I used some skatter trees in my scene and it rendered just fine

Then I needed to clear them…now the problem is that
When I hit render even though I don’t have any skatter objects in the scene…the render stops at the very first beginning and it appears in the frame buffer that what makes the render stops is that they are loading bitmaps from skatter library…even though I cleared all skatter objects in the scene.

I hope to find the issue and fix it
Thanks all

Hi @Bassant_Barsoum
Thanks for the bug report, I added it to our todo list.

Does it work again when you restart the render?

It worked, but only after I cleared skatter objects from vray geometrics and cleared all skatter materials from vray material panel.

1 Like

I’m investigating the bug but I cannot reproduce it.

You said that you cleared trees
How did you do it exactly?

Can you describe the exact steps to reproduce this?

I cleared them by selecting the trees and pressing delete…but they were still in “geometry” tab in vray and the material of the trees were in the “material” tab

Let me add that…I didn’t have that problem when I deleted assets from vray cosmo, even though I selected them and pressed delete…and they were still in the geometry and material panels.

If that didn’t reproduce the bug…I would try this again to see if I would have the same problem.

@Bassant_Barsoum I tried again but without success.

We actually implemented a safety mechanism to avoid the users deleting an object used by V-Ray or other renderers. When you create a Render Only composition, you might have noticed that Skatter creates a hidden & locked group that contains the objects so that even if the user deletes the object and purge the model, it’s still somewhere in the model (see Outliner’s screenshot).

Maybe that didn’t work. Please let us know if this happens again.