Reinstalled Skatter v1 and having issues...

I’m still using v1…

In the past, I would use a Skatter from the Skatter Library, then select the host.
Add another Skatter from the Library and select a host…it would yell at me about having a render still open, but usually, it would save it to previous to the render list.

Now I can’t get it to save a second Skatter selection to the render list.

Is there a way to actually save it to the render list…do I have to click on something to have it accept the setup and move on to the next Skatter selections?

The message I get is “you have pending changes that were not generated, are you shure you want to close the skatter dialog?”
How do I save bending changes???

It also considerably slows the opening of files once I have started creating my first render setup. Is that common? In fact, currently, I cannot get into my sketchup model because is taking forever to load. I opened on another machine without Skatter and it opened immediately…I have been waiting 5 minutes and it is still spinning.

Finally opened.

I already have a “Skatter 1”, but it isn’t showing up on the Render list once I start this new Skatter…and Skatter 6 won’t show up either.

What am I doing wrong?

Then it won’t let me add anymore geometry…and when I go to close the Skatter dialog box I get this…

While I have a thread going…
What the hell causes this?

Is v1 not supported or is it because I posted on a Sunday?

Hello…is there anybody out there?..

Would v2 fix all my problems? I just need this to work…

Kind of figured out the problem with the weird patterning…normals were reversed on a few of the triangles…
Still won’t save a Skatter to the Render list…or I don’t know how to do so…so, I can only render one skatter selection…can’t do anything other than grass. Kind of limiting, and I have to start by deleting the old Skatter 1 that it wants to hold onto.

Hi @marvins

That’s strange that Skatter 1 just starts misbehaving as we haven’t released any update in quite some time.

The way it should work is that a new entry appears in the Render list if:

  • you’re working in “Render only” mode
  • you click “Generate”

If you’re not in Render only mode, the generated instances directly appear in SketchUp so there’s nothing in the Render list.

Have you created a scattering with a very high density?

When starting up, Skatter generates those Render only scattering automatically and it can take some time depending on the density.

You can disable this with the “Do not compute disabled setups at startup” option. But of course, you’ll have to generate them manually.

We still provide support for v1 but it was sunday indeed, and monday was a national holiday in our country :slight_smile:

Thanks for the response!
Let me spend some time with your reply and get back to you with answers.

I guess I was trying to large of a surface to put grass on. I was able to finally see it save into Render when I tried it on a much smaller model.

1 Like