[Release] Skatter 2.1.1

This update fixes several bugs reported by users and especially focuses on V-Ray rendering in order to offer a more robust experience.

Bug fixes

  • V-Ray: fixed nested objects sometimes not rendering.
  • V-Ray: fixed interactive renders being needlessly refreshed when a composition is computed for the preview but not generated.
  • V-Ray: improved performance by ignoring compositions that have not changed since the last render.
  • Performance: fixed a memory leak due to internal raytracing data not being cleaned up after it becomes irrelevant.
  • Export: fixed exported files named with non-latin characters generating errors when importing them later. Skatter compositions exported before this fix will unfortunately remain faulty but new exports will work as expected.

How to install this update?

You can either:

  • Start Skatter and let it automatically update



My skatter has stopped working after that update :frowning:

I couldn’t update that automatically because after every restart skethup the update window appeared again.
I used the rbz package and I installed that manually.
that is the result:


Hi @marcinn
Does a computer restart solve that?

Thank you.
That solved problem of skatter working. But unforntely the update didn’t solve a problem of not rendering elements in render only mode :frowning:

below there is an example of my current work. Yesterday I created such a scene with skattered plants. Sometimes the rendering worked, sometimes not. I hoped that the latest update fix the issue, but as it is in the picture - skatter still doesnt work.

1 Like

Also in new scene there is an issue that some groups appears in the picture in render only mode, but for example 3d bazaar grass not:(

I am having an issue with skatter not showing objects in render mode.

At first I thought it to be a vrscene issue in my existing file

, but now realizing that sometimes a fresh file with the most basic cube and plane to skatter on don’t render at all.

Using the latest Skatter, Sketchup 2021, and Vray 5.20.01

I was previously using skatter 2.0.3 and things were working pretty fine, and since i was getting notifications to update I figured now was the time. I tried rolling back to 2.0.5 which had problems skattering VRSCENES… and now I am back to 2.0.3. I just wish i didnt upgrade my composition (then save) in my current file as now I need to reset my compositions up


There was an error in our server: it wrongly sent the 2.1.0 version instead of the 2.1.1.
That’s why there are still Render Only issues.
Sorry for the confusion!

Please try again.

I had downloaded the skatter_2.1.1.rbz file directly from the forum (and file named as such) and had the render-only issues with that version. (It was seemingly not actually updating to that version in-sketchup, and as you say was sending the 2.1.0). Was the rbz also actually the 2.1.0 version? (it did show up as 2.1.1 in the extension manager)

@brandonbergemgmail-c In that case, you had the correct version.

There’s a known issue with vrscenes. We contacted the V-Ray devs about it.

However, in a previous comment you say that even the most basic cube doesn’t render. Render Only should work ok except when using vrscene/V-Ray proxies. So if it’s not your case, please send a file with your issue to [email protected] and we’ll take a look. Thanks.