Render only is not visible in vray render

SketchUp version : 22.0.354 Sketchup Pro 64-bit
Skatter version (Skatter dialog > Options > About) : 2.1.5
OS : Windows 10
Description of the issue :
When I check “render only” objects are not visible in v-ray render (v-ray for sketchup 5.20.06). Could you help me please?
Thanks Pavel


Does it happen for all your models?
After checking Render Only, did you generate the composition?

For all my models I think. Of course after checking I generate composition.
A few weeks ago it worked great - new version of SU? or Skatter? I dont know

Can we schedule a TeamViewer session so that I can try debugging it directly on your machine?

Thanks a lot. Today’s update (2.1.6) solved that problem. Thank for you offer and time. Pavel


Unfortunately version 2.1.6 still doesn’t work for me - as soon as model is closed and reopened (regardless of re-generating the composition) grass will not render. Have to uninstall skatter and reinstall every time and restart sketchup or keep the same model open for it to continue working. Cannot find an answer.

I’m sorry I dont have problem with that. Everything goes ok. Until solution you can try vray’s fur as grass. Result is similar.

Same proposition as I offered Pavel: can we schedule a TeamViewer session so that I can try debugging it directly on your machine?

Hi there Thomas that would be great! Cheers, Nick

Ok I’ll get in touch via email.

Thanks Thomas - that would be much appreciated

Can you check your inbox? I sent an email on May 6th

Skatter version 2.1.6
Sketchup version 21.1.332 64-Bit
V-Ray for SketchUp - 5.20.06 - (257461 474751010) - Apr 13 2022
V-Ray Core - 5.20.24
V-Ray NeUI - 4.2.5 - (1340357 9e276466) - Apr 12 2022
V-Ray AppSDK - 3.10.00

Objects render in model mode only, when in render only mode do not render.

Genereating regenerating opening reopening change nothing

Could you advise please?

@Thomas Just an update uninstalled all elements (vray & skatter) cleaned all folders reinstalled fresh - on switching teapot in the Composition Manager causes a splat with 2.1.6. when the file is saved with settings it causes splat on opening, This is just a file with one plane and tall grass from 3d Bazaar

Hi there Thomas, was this for me (re email on the 6th) as I haven’t recived anything this end - Just went back to check, Cheers, Nick

@AMGRY I think you just got a notification. I replied in this thread, and @Thomas did not come back yet. It looks like Vray 5.20.06, Skatter 2 and SU2021 don’t like each for the moment.
I uninstalled all software and installed it back and could make one render basic render with two boxes. When I imported the 3d Bazar model, it splatted. Also, when old scenes made in an older version of VRay crashed at opening or at render or did not render compositions.

@dascorp @AMGRY

I will send you guys emails once again.

@Thomas I downgraded to 2.1.5 and can render only render with the newest vray. But only on newly created files. When I load old scenes it either splats or do not render render only elements.

so further investigation is needed

I had something similar to this this weekend. I must admit i only just started using skatter.

I had imported to chaos cosmos assets and scattered them about. It would work for a while but when I closed the file and reopened it, I would have to click the skatter lists button and sometimes generate it again.

I’ts not a big deal to me as I found a way around it but something isn’t correct. Also I find it annoying that everytime you go to edit a skatter group, it pops open a new skatter window???

Anyway, it did what I wanted to and my client was happy.

Could you send us the file at [email protected]?

Does this happen with other files?