Render only with Vray 5 still unusable

SketchUp version : 2020.1
Skatter version (Skatter dialog > Options > About) : 2.1.3
OS : windows 10
Description of the issue : render only feature is still unusable with vray 5
Are you able to reproduce the issue every time? (If yes, how?) :yes
Error in Ruby Console? (Window > Ruby Console) : no

i’m confused to say i’m very disapointed using skatter, while i was very excited waiting for working with.
I can’t use render-only option with vray 5, while it’s the main feature I expect from Skatter.
I have to compute the scattered objects in the model in order to render them.
This issue is reproductible every time I work on a project. Sometimes, the rendering is effective on first hit, then saving sketchup file, closing and re-opening it…and then it’s a headheck to understand why it doesn’t work at all…


Replying to myself and adding details of the experience.

I CAN use render only mode when i use the following trick:
-Work in sketchup 2021 and Skatter. Not launching Vray Rendering.
-Open the same file in Sketchup 2020 (With open Newer version Plugin by Eneroth)
-Save and close file as it is (2020 version)
-Open in Sketchup 2021
-Hit render…and voilà !

So…what is going on?
Does Skatter needs to consider a file to be a brand fresh new stuff ?
I would like to have some users comments and report of their personnal expreriences.

Best wishes and happy New year to all

What is your exact version of V-Ray 5?
Does it happen with any object (even a simple cube?), assets from the 3D Bazaar, or only with a specific object?

If you do everything in SketchUp 2020, does it work?

SketchUp version is 21.1.332
Vray Version is 5.20.03
Skatter version is 2.1.3

Ruby Console info when rendering:

live_scene(365):info: “Initializing Renderer”
Laubwerk: V-Ray callback
Timer stopped by wait - update proxies now called from wait loop
backup write…
live_scene(365):info: “Exporting model”
live_scene(365):info: “Exporting model: Done (79.3951862 seconds)”
live_scene(365):info: “Starting render”
live_scene(365):info: “Starting render: Done”

It happens every time, with every assets (from 3d Bazaar, own library or Cosmos; exploded component or not, full geometry or proxies)

If I work with SketchUp 2020, the issue is the same : fresh new file, new skatter composition and first render happen fine. But, when i save, close and re-open the file; render-only doesn’t work.

Despite this issue, I would like to congratulate you guys for your incredible work ! I assume it’s a headheck to track, find and fix theses bugs. I can’t wait to work painless with Skatter 2 !


We are having a hard time reproducing this issue.

Your Ruby Console log shows that you are using Laubwerk. Could you try to remove it and see if the issue persists?

Unfortunately, I have already tested this kind of configuration. A fresh clean install of SketchUp with only Skatter and Vray plugins installed.

By the way, my trick described before (open file in SketchUp 2021 ->Save → open in SketchUp 2020-> Render only working-> open in SketchupUp 2021) doesn’t work anymore.
…totally lost…

Could you please try this older version? (2.0.0)
You should probably manually uninstall Skatter before installing this older version.

We made some changes after that version in the interaction between Skatter and V-Ray, and V-Ray also released an update in the meantime.
So this will tell us if the issue comes from our changes, or from the V-Ray update.


I had the same issue, as soon as I went back to the older version above, as suggested - it’s back working again in ‘Render Only’,

Have you tried with v2.1.5?

Have you tried using the V-Ray File Path editor?

It’s under Extensions: V-Ray: File Path Editor.

Organize it by Directory then highlight the bitmaps and geometry for your proxy and click on Repath which will then open a window for you to locate the directory where everything is located.

I just tried it and it worked since I’m experimenting with V-Ray and Skatter right now.