[Resolved] Scatter Crashing Sketchup on iMac


I’ve just purchased Scatter, and seem to be having problems.

I created a 3m x 6m rectangle. Scattered some grass on it. Rendered in Thea for Sketchup. Seemed ok.

Tried to add some bushes. It added one. When I tried to change the settings, the spinning rainbow wheel appeared, and Sketchup locked up. I had to do a Force Quit on Sketchup.

I’m using Sketchup Pro 2017, latest release, on an iMac 27 Inch, i5 3.4GHz, with 16GB of RAM and 2GB NVidia GeForce 775M GPU.

Any help would be appreciated, as I’ll just have to not use it if it’s unstable.

Other than this, Sketchup has been extremely stable on my machine.

Kind regards



So, an update…

I caused it to happen when I changed the “Distribution” value for ‘Random’, to 1 item per unit, (it’s default value for Bushes was 0.0002). I think that this means I tried to ask it to produce 1 Bush per drawing unit, which in my case is mm’s. If this is the case, I can understand why it struggled.

I avoided this, and it seems to work perfectly. Looking forward to using it in my work.

Kind regards


This is indeed the case :wink:
The limitation is your system’s RAM. If the RAM is full, SketchUp crashes.

Thank you for the reply Thomas. Very much appreciated.

Yes, once I figured that out, no more problems.

It’s superb as well, so I thank you again. Works brilliantly with Thea too.

Kind regards


Hello i have the issue how can I empty the RAM?
thank you for your help.

Hi @michael
If you need to free up a bit of RAM, you have to stop background software that you’re not using such as browsers, music apps, etc… Unfortunately, other than that there’s no silver bullet apart from adding more RAM to the computer.

OK thank’s for your Help!

1 Like