Skatter 2.0.2 update: an error occurred during initialization

Hi @merwan im getting this nasty error after i updated to 2.0.2
and im unable to use skatter anymore after the update.
i downgraded to 2.0.1 and it works fine.

Kind regards


(moved to a new topic)

Hi @juancarlosestereovis

That’s quite strange. It looks like one of the file installed by Skatter cannot be accessed because it is locked by something else.

  • Do you have several instances of SketchUp running when this error appears?
  • Have you tried restarting your computer? (sometimes, crashed programs lock files but this is often solved when restarting)
  • It might help to uninstall Skatter 2.0.1, restart SketchUp, and then install 2.0.2 from scratch.

Hi Merwan!

I always close all but one window and install and restart (sketchup not the pc) when i update skatter.
i will test it today with your advice and see if it gets solved in some of those ways, Thanks!



1 Like

I’m having the same problem here. I’ve tryied to uninstall skatter 2, restarted sketchup but I still get the same problem. The 3D Bazar in can open normally tough…

Hi @pedroseabramedeiros

We had several users reporting this when uninstalling/upgrading Skatter.
It seems to be caused by SketchUp locking some Skatter files. We haven’t had time to fix it yet but it’s on our todo list.

Usually, the issue resolved by either restarting the computer or by manually stopping the zombie Sketchup.exe process with Windows task manager (ctr+alt+del).