Skatter 2 does not send objects to V-Ray

Hi. Me again: Frank from Germany.

Skatter 2 is still not working properly. I want to scatter foliage from Quixel Megascans, which is already “transmuted” and imported into SketchUp. Most of the time, I can skatter them, but they don’t show up in V-Ray renderings. This is a permanent error. I still use Skatter 1, when I’m too frustrated.

Where is the problem? Do I do something wrong?


Would you be ok with doing a remote-control session (with TeamViewer) so that I can try debugging the issue directly on your computer?

Can you try this version?

Hey Thomas,

so sorry, I did not answer yet. Moved into a new city: busy, busy. :wink: Well, I’ll install this new version and check it out … Thanks. <3

What I did meanwhile, is to change all foliage components into groups and skatter only groups: Works more stable, I guess. Did not get any “real” error messages from V-Ray anymore. Sometimes the skatter still disappears, then a complete restart fixed the problem.

(Sometimes the foliage disappeared in Version 1 too. So perhaps it’s a legacy-problem. Or was … :D)

Thanks again.



Ah, this is no real “update”; I already use this version … :slight_smile:

It is, it’s a modified version of 2.1.6, see the “b” at the end of the filename.
It’s still marked as 2.1.6 because the 2.1.7 number will be used for the official public release.

Ah, okay … Is there a way to install this version without completely deinstalling the previous one? I am afraid to break the current skattering, which ist functioning right now … When I install the “skatter_2.1.6b.rbz” nothing happens … or I get no message, that something “changed”. :slight_smile:

Nothing will break your existing compositions, no worries :wink:
You can safely delete the old files and install the new one.

Done. Aaand: It’s broken. :smiley: You have to make a new seed for every “arrangement” to get your skatter back.

I’m not sure I understand. Compositions working with 2.1.6 don’t work since you installed 2.1.6b?

Hey Thomas.

I de-installed the 2.1.6 and installed this new B-Version. And - as I feared ^^ - the skattering was gone. No preview in the editor also. So I took every skatter from the “list” and made a new “seed” for each of them, after that it worked again. But it was a new skatter, not the old ones I already made. :slight_smile: