Skatter breaks copy & paste between documents in SU 2020

**SketchUp version : 2020 (20.0.362 latest)
Skatter version (Skatter dialog > Options > About) : 1.4.12 (latest)
OS : Mac OS Catalina 10.15.3 (latest)
**Description of the issue : If the Skatter Extension is enabled, copying a group from one Sketchup Document (model) then Pasting into another document does not work.
Are you able to reproduce the issue every time? (If yes, how?) :slight_smile:
Yes, here’s an example of steps that will show the issue:

  1. Create New model
  2. Create a cube (draw rect, push/pull to make cube)
  3. Select it and group it
  4. Copy
  5. Create another New model
  6. Paste

Nothing happens. This is the step where you normally see the four-way arrow cursor and the object that you’re pasting, and can then drag and click to select the location where you want to paste. Instead, the four-way arrow cursor appears for a brief moment, then nothing else happens, even if you drag and click.

A. If you use “Edit > Paste in Place” instead of the standard “Edit > Paste (Cmd-V)” for step 6, it pastes correctly, but of course this doesn’t allow you to choose where to paste the object.
B. Also, if it’s not a group (skip step 3), it also works.
C. If you disable the Skatter Extension, pasting works properly.
D. This was not an issue with SU 2019, started with SU 2020.

Error in Ruby Console? (Window > Ruby Console) :

Only content in Ruby Console is:

---- Skatter 1.4.12----
Regenerate render instances from attributes : 2.3e-05 s
---- End ----

Thanks for the detailed report, we will look into it.

I concur this is happening for me as well. Just upgraded to SU 2020 yesterday from 2017 and installed the latest Skatter plugin. I have identical OS specs as listed above; everything worked for me in SU2017 with an older plugin version. Only way around it is to disable/enable Skatter as needed and restart Sketchup, which is undesirable…

Yes! This is definitely happening. I spent a couple of hours going crazy because I could not perform the simplest of actions: copying/pasting from one file to another. After trying all I knew I contacted Trimble and someone there told me he had heard of a conflict with Skatter. By his advice I disabled Skatter and Sketchup went back to normal.

Could you guys look into into it, please? Skatter is too important to just forget it.

Mac OS Mojave 10.14.6, Sketchup 2020 (the latest build).

Best regards.


Same problem for me with OSX Mojave and sketchup 2018

We have fixed the issue (actually worked around a SketchUp bug). Can you guys please try this version to see if it works correctly:

@bripiriegmail-com @eddski @edson @breh

Yes, this new version seems to correct the problem for me. Thanks so much for looking into this and getting an update out so quickly!

1 Like

looks good for me as well, thanks!

1 Like

Yes, working for me too. Appreciate the fix!

1 Like