Skatter makes Thea crash

SketchUp version :2016
Skatter version (Menu Window > Preferences > Extensions) :1.1.2
OS :windows 10
Description of the issue : crash when launching thea + ‘group… is missing’
Are you able to reproduce the issue every time? (If yes, how?) :yes, if you need the scene PM me

My sketchup scene seems to have a problem with Skatter. Whenever I open the scene again it tells me ‘group … is missing’ (see attached image.
skatter bug

I also had another problem with this scene : sometimes when trying to launch the TheaforSketchup window, it crashes sketchup instantly. I couldn’t launch the rendering anymore no matter how much I tried, everytime it crashed. So I finally resolved it by saving to sketchup 2013 and opening it there. After that it would tell me ‘group… is missing’ a couple of times but I could again launch the Thearender window. I just have to manually reselct the host geometries for my different skatter sets.

It only does that with skatters based on sketchup geometry, for skatters based on picked points set, there seems to be no problem.

if you need the whole scene PM me, I tried to cleanup and simplify the scene to send it to you but it doesn’t replicate the same error then, I can’t seem to locate where the problem is.


Indeed having the scene would be really helpful : [email protected]