Skatter not Rendering in V-Ray with "Render Only" ticked


#1

SketchUp version : 2018 Pro
Skatter version (Skatter dialog > Options > About) : 1.4.7
OS : Windows 10
Description of the issue : Skatter will not render all elements if the “render only” button is ticked when using custom scattered objects. It will only render ONE object. When I untick “render only”, the elements then render as they should. This is problematic when trying to render grass and large numbers of objects.

When I render the default assets that come with skatter, they render as they should with “render only” both checked and unchecked.

Is there a work around for this issue?

Images:

Are you able to reproduce the issue every time? (If yes, how?) : yes, by using any custom element
Error in Ruby Console? (Window > Ruby Console) : -


#2

Does this happen even when the scattered object is not a proxy, but a simple cube for example?

Could you send the files to [email protected] ?


#3

Thomas, I have submitted an email for your viewing. If I use a simple box, then it renders no problem. Can vray not render skattered vray scene/vray mesh proxy data?

Do I have to ‘bake’ or uncheck ‘render only’ all of my skattered vray proxies in order for them to render? If so, then this is problematic.


#4

This is an issue in V-Ray with VRScenes. Proxies should work fine, though.
Please report the issue to Chaos Group directly, as only them can fix the issue.