Sketchup crashes when selecting a host

SketchUp version :SU 2014 & 2017
Skatter version (Skatter dialog > Options > About) : 1.4.2
OS : Windows 10
Description of the issue :

I’ve just changed PC, and reinstalled all my previous software etc.

Sketchup will crash out when trying to select a host for the plugin. I can bring up the library, load in a proxy object, however when I try to select a surface host, the program freezes and then closes immediately. This also happens when I try to select individual points rather than a surface.

Are you able to reproduce the issue every time? (If yes, how?) : Every time this happens. I’ve tried installing SU 2017 as well, and attempting the same process and I have the same result of the program crashing immediately.
Error in Ruby Console? (Window > Ruby Console) :

Software crashes out so cannot select and copy, I have uploaded a screenshot of the last view of it before it closes though for both SU 2014 and 2017:


Please go to Windows 10’s Settings Panel (Start > Settings), then “Network & Internet”, then “Change adapter options”.
Take a screenshot and send it to me.
I need to see how many network adapters you have. I have seen once a very rare crash in Skatter when a user had too many adapters. Disabling most of them fixed the crash.

I have a .dmp file and the SU log file I can send over if that’s any use?

Can you temporarily disable the adapters that are not in use? (“Bluetooth Network Connection” and “Wi-fi”)
Then try again.

Regarding the .dmp files, unfortunately they are not useful in this case.

I’ve disabled those adapters and retried, though the program still crashes out. I manage to grab the screenshot below before it closed:

I tried again, this time disabling the ‘Live Preview’ within the Skatter options, and when I select a host, it doesn’t crash but gives this error within the Ruby console:

DL is deprecated, please use Fiddle
Volume OK
MAC Fails

_---- Skatter 1.4.2---- _
Regenerate render instances from attributes : 0.0 s
---- End ----

Skatter overwrote Vray’s ‘write_to_xml’
Volume OK
MAC Fails
Error: #<TypeError: no implicit conversion of nil into Integer>
C:/ProgramData/SketchUp/SketchUp 2014/SketchUp/Plugins/jbb_skatter/rb/generate_objects.rb:58:in srand'_ _C:/ProgramData/SketchUp/SketchUp 2014/SketchUp/Plugins/jbb_skatter/rb/generate_objects.rb:58:ingenerate’
C:/ProgramData/SketchUp/SketchUp 2014/SketchUp/Plugins/jbb_skatter/rb/tools.rb:94:in `onLButtonDown’

Could we set up a Teamviewer session so I can try to debug directly on your machine?
To discuss the details, contact me at [email protected]

Hello, I am with the same problem, can you help me?Please.

Hi Guiherme,

Same question: Can we set up a Teamviewer session so I can try to debug directly on your machine?
Contact me at [email protected]