Texture bug


#1

When exporting as Thea proxy, the texture is displayed correctly in SketchUp 2019, but when rendered in Thea for SketchUp, it flips 360 degrees as in Transmutr!
Coffee cup.rar (2.8 MB)
Texture1


#2

We just found an issue that flip textures in the Transmutr preview: https://forums.getskatter.com/t/uvs-doesnt-show-properly/1644/3
But that should only happen in the Transmutr preview.

I can reproduce the issue with the flipped UVs in the Thea proxy (if it’s not a proxy, it renders fine in Thea). This is very strange, we will investigate.


#3

If you have other models that show the same issue (flipped textures in Thea proxies), please send them to us.


#4

I sent the files by mail


#5

Thanks!

I’ve done some testing, and it seems that textures in Thea Proxies exported by Transmutr are always flipped. I don’t know how we missed that, but it seems this bug has been present since v0.3.0 (the first version with Thea Proxies export)

@jql @juancarlosestereovis @Peter_Stoppel @duanekemp @gwengosch @pixero Can you guys confirm? (that textures are flipped in Thea Proxies, but not in SketchUp. You will see them flipped in the Transmutr preview in v0.3.4 but that is another bug)


#6

As soon as I can. I’m a bit charged at the moment… but, yes… this would be good to know. I haven’t yet made proxies via transmuter… thanks for the heads up.


#7

No pressure, I just wanted to confirm my observations that it happens everytime.


#8

Thea proxie test:

there is definitely a bug…


#9

it´s happening to me too on all the models, even from the viewport all textures are flipped, saved to sketchup format they are! ok.

i can confirm it persists on all exported proxy formats frm 3ds and obj files


#10

Thanks for the confirmation, guys!

From my tests, it seems this bug has been present since v0.3.0
I don’t know how we all missed it haha ^^


#11

The issue will be fixed in the next version (0.3.5 or 0.4.0)


#12

I first tried a FBX file of some food on plates. Couldn’t get it to work with textures… gave up and tried with something simpler. I tried with a banana .obj file. when connecting mats, only the bottom half textured, and when exported as proxy… the box was created but nothing rendered. There was actually nothing in the proxy to render. So, I’m going to have to test some more.


#13

Any other Thea users having issues with models rendering in Thea V1.5?
My exported SU2019 Thea V2 files seem to render… but, not if opened with SU2018 V1.5… all renders black as if texturing lost the maps.


#14

For now we only support Thea v2 : https://www.notion.so/lindale/Transmutr-FAQ-166e85969c4e402ca38d4ed9b6ab5607


#15

Thank you for the confirmation. Much appreciated.