Textures from Library not loading on Vray 2.00.6x

Hey Thomas, i am noticing that grass in the library is failing to load the maps, here is what the Vray progress window reports:

Bitmap file “SKATTER_LIBRARY_PATHskatter_grass_diffuse_03.jpg” failed to load: [LoadImageFile] Failed to open file: no such file
Bitmap file “SKATTER_LIBRARY_PATHskatter_grass_diffuse_01.jpg” failed to load: [LoadImageFile] Failed to open file: no such file

Any ideas? i have been manually remaping the textures to a rendering success, thought i pass this along to see if there is an easy fix.

On my computer the Skatter library installs here:
Is that right?


By any chance, did you load the components manually? Or does it happen when loading them through the Library?


i can try library loading.

This is normal if you load them manually. They are made to be loaded through the library.

Sorry to butt in but this happens to me as well even when loading through the library. When I load through the library (have tried grass, trees and bushes etc) and then hit render the proxies are there but all materials are grey. When i look up the materials in vray browser the path is listed as : SKATTER_LIBRARY_PATHskatter_grass_diffuse_03.jpg.

I then manually swap out the first part with “C:\ProgramData\Skatter\Library” for each path and then it works okay. This for me is a new issue in the latest version as it worked fine in every older version.

The workaround doesn’t take long for me so not a huge problem but if there is a way to fix it that would be great. Thanks again for any help.

Hi adorodriguez,

Can you confirm that it happens in a brand new file as well?

Hi again,

I have done some further testing. It is quite strange but I do get the error in brand new files as well. I have tried most of the assets but get slightly different results with each. I’ll explain as best i can but it might get a bit long winded sorry.

When I create the first instance of skattered grass in the new file the textures are missing (as per post above). The proxies render with a bright green colour that is the diffuse colour assigned to the material.I have tried full geometry, proxies and render only with the same result. Strangely though if in the same file i then go to create a different type of grass (say “border” rather than “large” of the same height grass or even a totally different one) a new set of materials load for the 2nd set of grass and that one renders perfectly. The first set of grass still looks wrong though. I have tried every combination of the grass options and it is always the same result. The first one doesn’t work but subsequent ones do work.

Other assets function a bit differently.

Daisies seem to work well every time.
Bushes don’t ever work. They render grey which is the diffuse colour.
Trees don’t render at all (ie nothing appears - not even the grey colour)
Rocks render jet black
Water Lillies black
Gravel renders grey but appears black in material browser

I can get around it all by manually swapping out the images so not a huge issue.

Am i correct in saying that the licence allows skatter to be installed on two machines provided that it is only actively being used on one at a time? If so i will put it on my home machine and perform the same test tonight. It is quite possibly something that I am doing wrong.

Thanks for any help.

Thanks for the further testing.
Could you open the Ruby Console before loading the presets, and tell me what appears in the console when you load presets from the library?

on my end i can report that my issue was that i was manually loading the proxies. Loading from library resolved the issue