Transmutr Auto Import not working


#1

Is it possible, when you run Transmutr from within SketchUp to auto-import when it is down converting? My guess would be that you would have to choose which file to import if you converted multiple types.


#2

It should already be the case.

When Transmutr is opened from SketchUp, when you click ‘TRANSMUTE’ and set the save path, Transmutr should close and the file should be loaded in your model as a component.
It’s not the case for you?


#3

No. It never closes and doesnt import the model.

Also, I looked in my component browser and it doesnt show anything loaded.


#4

Please open the Ruby Console before opening Transmutr, and tell us what appears in the console.


#5

Absolutely blank. Nothing appears in the console.


#6

Even on a fresh start?

  • Open SketchUp
  • Open the Console
  • Start Transmutr from SketchUp

You should see something like:

Transmutr connecting to local port 1200…
Transmutr connected


#7

Transmutr connecting to local port 1200…
Transmutr cannot connect


#8

Ok maybe the port is already used by another application.

Go to Extensions > Transmutr > Settings and change the port to something else (like 23547 or similar).
Then try again


#9

(I just noticed this setting is not saved between sessions, I’ll fix that)


#10

That doesn’t seem to work either.


#11

Working with our IT person at the office, he tried something and came up with this - not sure if its helpful to hunt down the issue.

When telnetting to the local host’s port 1200 (using PuTTY), I get this error message. Port 1200 does seem to be responding, but I don’t understand what this error means.
Putty


#12

This error is appears because the message sent from PuTTY has an unexpected format. You can discard it.

Please Go to “Control Panel > System and Security > Windows Firewall > Allow a program or feature through Windows Firewall”, and make sure Transmutr is allowed on Private network, and that its checkbox is ticked.

firewall


#13

There was no entry for Transmutr. I added it and gave it permission. Still not working though unfortunately. This is Windows 7 inside our work domain so I will try it on my home pc with Windows 10 see how that goes.


#14

Do you know if there is another firewall on your computer? An antivirus maybe?


#15

In our office we have Kaspersky running on all machines.


#16

Can you disable it temporarily to see if it’s blocking Transmutr?

SketchUp and Transmutr communicate via the local network. This may sound a bit weird, but as they are separate applications/processes, we have to do it this way.


#17

I installed Transmutr at home, outside the Kaspersky network and when I run the plugin in SketchUp, the console shows no message, but the file does import… but… SketchUp gave an error message that "something was wrong with the model and it asks to fix, which I said yes and then it imports fine.

I will have the IT person look at our Kaspersky settings.


#18

Ok good.

The SketchUp popup appears when you import a model with some weird geometry that SketchUp doesn’t like. We could trigger the ‘Fix’ in Transmutr using the SketchUp API, but we decided not to, and let the user decide. Because sometimes, you might prefer not to fix it (it’s not a big deal) to avoid loosing faces or stuff like that.


#19

Merwan, Good Morning. My Transmutr is not opening the block directly in Sktchup.


Possible bug [Blank screen]
#20

Hi @LucianoJMM. Do you have the white screen issue too?

Does transmutr work when you open it without Sketchup?