Unable to render large portions of grass

I love this plugin and it works just fine with the integrated grass pack (endlessly as they say) but as soon as I change the grass models and use the Bekerman’s Meadow Pack, SketchUp freezes and stays like that forever until I restart it.I am using VRAY 3.4 which is so much better at render times than the previous versions, but I don’t really understand why it takes sooo long to render using Meadow pack. Even with a few patches of grass it takes too long. I even disabled all material effects until the only one remaining was the diffuse itself. I’ve seen people on Youtube rendering fast, just like it does with the normal grass preset from Skatter Library, but not for me. Any idea?

Am I doing something wrong, maybe the skatter options… I always use “render only” on skatter, is it possible to create proxies somehow differently? I even created my own library entries hoping to solve the issue, but in vain.

I seriously need help, this plugin is amazing for my projects. My ‘workstation’ is actually a laptop but it even rendered 32 megapixels photos with many details and ultra high resolution textures without crashing or anything (once, it handled a 1.2GB SketchUP file - which is enormously, but it rendered it just fine). For a laptop it does its job remarkably good, that is why I think it’s not the cause. It must be from something else.

Thank you.

So the render never starts? It just freezes forever?

I fixed it. Seems it had a problem with VRAY.

If someone is reading this looking for the key to this issue, do these steps:

  • Don’t use skatter library to add your own models. Import the model you want to scatter into SketchUp.
  • Make sure it’s grouped. Select it, then use “Export Proxy” button from VRAY menu and save it somewhere in your PC.
  • You will be asked if you want to replace your model that’s already in the workspace with a proxy. Don’t do that - sometimes it bugs.
  • Delete the model and use “Import Proxy” button from VRAY menu and select the proxy you saved before. Add it just once in your workspace, Use it as a skatter object and spread it across your host plane.
  • Hit render button, wait up to a minute for VRAY to calculate the necessary things - If it doesn’t and freezes, wait a few more minutes. If nothing happens, close SketchUp, uninstall VRAY, delete the windows temporary files, reinstall VRAY.
  • That worked for me and I haven’t had a problem ever since

Hope it helped :grinning: