V-Ray warning when opening proxy file >> Update to V-Ray 3.60.03


#1

Hi all,

In addition to the above I ran into the following isue:

When exporting an .obj file as a V-ray proxy the following error pops up when trying to opening vray inside of sketchup:

" The model you are trying to activate appears to be a V-Ray GeoMeshFile object. Activating it will remove serialized V-Ray data from the model. Do you want proceed?

If I say no, it won’t open vray, if i accept it, V-Ray just renders the bounding box.


Started testing Transmutr and ran into the following issues
#2

HI @Pixual,

Did you also run into the Blue Screen of Death error?


#3

No BSOD here, opening Transmutr went fine. I only had to disable my avast anti virus while installing the program.


#4

Hi @Pixual,

The proxy .skp file generated by Transmutr is intended to be imported in another model, as a component.
This component is the proxy that V-Ray will see and replace by the vrmesh.

If you open the .skp file directly, V-Ray understands that it should actually be imported as a component in a separate model, and displays the warning you reported.

This is expected behavior.


#5

@Thomas, thanks for the quick reply

I tried the following, correct me if i’m wrong:

  1. Open a new sketchup file
  2. Open up V-ray
  3. Inside sketchup, go to file > import
  4. selecting the proxy .skp file generated by Transmutr

When doing this, I’ll expect a geometry file in the V-Ray geometry tab where the .vrmesh is connected to the sketchup object. But this stays empty.
When rendering, there is nothing visible.


#6

Hi Thomas,

Do you need my .obj file for testing purposes maybe?


#7

Yes this is correct.

What version of V-Ray are you using?
Can you send me the generated .skp file to [email protected]? Thanks


#8

This is my current V-Ray version:

V-Ray for SketchUp 3.60.02

Build: 1240 Hash: 31b08bcd Date: Feb 16 2018
V-Ray NeUI Version: 1.1.3 Build: 1240 Hash: c6039e65f Date: Feb 16 2018
V-Ray Core Version: 3.60.04
V-Ray AppSDK Version: 1.24.01

I will send you the files. Thanks for looking into it.


#9

Thanks for the file.
It looks like the .vrmesh was exported correctly, and the .skp file has all the right attributes and materials.
The proxy path saved in the .skp file is “C:\Users\Pixual\Desktop\Export_Transmutr\20181218_test_export.vrmesh”. Is this correct?

On my machine I had to tell V-Ray where to look for the .vrmesh file, because obviously I don’t have the file in the same place.
Please go to Extensions > V-Ray > File Path Editor, and send me a screenshot.


#10

Yes, this is the correct filepath.
In my filepath editor all the materials are connected ok. There isn’t a geometry file i.e. .vrmesh file in the filepath editor, so i can’t relink it.

See the attachment image:


#11

Please try to update V-Ray to 3.60.03


#12

This seems to fix it! Thanks!