Vray doesn't render skatter grass


I noticed an issue rendering skatter grass after I updated from Sketchup Pro 2017 to 2018.
I can render any kind of proxy except skatter grass.
When Vray does “Compiling geometry” it doesn’t matter how much grass I render but the image doesn’t process.
The frame buffer stands black.
I just noticed something weird happens in the history (see image attached): last image has “-447h”, so I’m rendering back in time!!

Any guess?

Thank you,


Does this happen in a brand new file?

Yes except if the grass portion is rather small.
I tried a 7000 pieces area, which I suppose is small, and did as above.

I’ve never had problems with rocks, trees or gravel and I’ve already rendered several times with much bigger surfaces.

I think it could be related to the update I did from Skp 2017 to Skp 2018.
Never had problem before that but who’s having problems between SketchUp, Vray and Skatter?

Do you still have SketchUp 2017 installed? If so, can you now try there?

What is your hardware?

Unfortunately I uninstalled version 2017.


  • MSI Z170A Gaming M5
  • MSI GTX 1070 Aero 8G
  • Corsair Vengeance 2x16 GB
  • Samsung Hdd SSD 850 Evo 250GB
    DxDiag.rar (7.3 KB)

Try this :

  • Create a new SketchUp file
  • Open the Skatter Library and load a grass preset
  • When the Skatter dialog opens, do not pick a host (don’t apply the preset), and close the dialog
  • Go to SketchUp’s Component window, click on “skatter_tall_grass_01_large_proxy” (or “medium”/“short”) and place the component in the model
  • Try to render

Your solutions works but the problem remains because Vray sort of freeze when dealing with the Compiling Geometry phase.

And does this just with the skatter grass, not with any other proxy component.

I already rendered skatter grass in large amount of items (270.000) previously. Now it just locks vray, that stops and is not able to render again without closing and reopening the file

Just to be clear, you mean that the single grass patch renders fine?


Selecting the skatter grass and pitch the individual component works, I can see it and vray renders it.

Selecting the skatter grass and scatter it on a small patch also works, as long as I stay below few thousands items, < 10k I would say.

Over that Vray freezes during the compiling geometry process.

I’ve tried with other grass proxies and it works without problems and that’s what I’m going to do now but I don’t understand why just the skatter grass stop Vray from working properly

This is very strange. This can easily happen on low-end hardware, but it is not your case.

have you tried to contact Chaos Group? As this happens on V-Ray’s side, they will probably be more helpful than I can be.

I’ll try then!

Thank you for the quick reply anyway and I’ll let you if I’ll sort it out.

Your plugin is awesome by the way!


doesn anybody ever had this issue?
still having trouble

thank you

Chaos Group wasn’t able to resolve your issue?

I have the same problem, anyone solve it???

If this is the same issue, I’d answer the same thing : This is a V-Ray issue, so this is out of my control and you should contact Chaos Group.

If it’s not exactly the same issue, can you elaborate? What exactly doesn’t work?

Unfortunately, this is the same situation. Thanks a lot for Your responde :slight_smile:

I just started using skatter a few weeks ago. Everything renders fine as long as I don’t use proxy’s, except for grass. Grass just locks up v-ray :frowning: