VRay Materials Not Wokring


Not sure if this goes here or elsewhere but I need some help with a small issue I’m getting.

I’m trying to render some simple plant textures with VRay but it seems it’s not applying the material and I have no idea why! The two images below explain what I mean by this. When I run a render off with VRay the skattered objects all appear as white squares without the plant material applied. The image below shows this where the one plant at the front is the original.

Broken skatter…

I then tried turning Render Only off which just gave me a load of blank squares. I could then apply the material to them like I would with normal geometry with VRay as shown below but this is defeating the purpose of skatter saving me system resources! Just to note this is a test file, I need to sort this for a project with some dense vegetation. I’m having the same issue in that file too!

Desired result!

Thing is, when I first tried skatter this morning with a test file and the same VRay materials and settings it was working fine! Any ideas how I can fix this?

Many thanks in advance

SketchUp version : 2014
Skatter version (Menu Window > Preferences > Extensions) : 1.0.4
OS : Windows 7 Professional 64bit
Description of the issue : See above
Are you able to reproduce the issue every time? (If yes, how?) : Currently yes.

Can you please send us the file…

The sketchup file and textures can be found here

This is probably happening because the material is applied to the component instances, and not to the geometry INSIDE the component.

Ah, of course. Knew I’d have missed something like that! Thank you so much for the quick responses!

Just to show anyone else what the difference is, the components on the left have the VRay material applied to the group, the ones on the right have it applied to the geometry inside as Thomas has pointed out!