VRMAT error


#1

Problems with VRMAT, does not open, only BITMAP images (JPG, PNG, etc)


#2

I’m not sure I understand your issue. What doesn’t open exactly? Can you be more specific?

Thanks


#3

In the material tab, I try to replace original material for VRMAT, it only gives me the option of Bitmap files. Vrmat material does not appear. I have a VRMAT file in the download folder that appears when I am in the folder (image 1). But through the Trasmutr it does not appear (image 2)

image 1


image 2


#4

Thanks, it will be fixed in the next version.


#5

But in Image 2, it looks like you’re in a different folder, in a different location…


#6

Thomas, thank you, it worked now. The material loaded with the V-Ray properties, but without the textures and maps. Any solution?


#7

Do you mean that the bitmaps are not present in the V-Ray material, or that the SketchUp material has no texture?


#8

Hi Thomas, so, I created a VRMAT material with asphalt texture and when I replaced it in Transmutr and opened it in vray, only the reflection and settings appeared correct. But the texture of diffuse and bump did not appear. It’s empty.


#9

Can you send me the VRMat file to [email protected]?


#10

I sent you an email.


#11

Thanks

Here is what I understand of the issue:
A VRMat file contains XML data, which is what V-Ray 1 and 2 used to store in the SketchUp files. So what Transmutr does, is store this data in the file, and rely on V-Ray 3 updating it to its new format (JSON).
The issue is when V-Ray update the XML to JSON, it finds a discrepancy: There is a diffuse texture in the XML, but no texture in SketchUp. It choses to follow the SketchUp material, and discards the diffuse from the XML. This is what you experience with your example.

When we import the VRMat directly within V-Ray, it is handled correctly. The issue is only when V-Ray converts data already present in the file (eg written by Transmutr).

I’m not sure how to fix this. We would need to find and extract the diffuse from the VRMat file, but there are so many different combinations that it may work only for the most common cases. There are many different V-Ray material types, they can have multiple layers each with its own diffuse, etc.

In Transmutr v0.2.1, the diffuse slot will be exposed in the UI, when the material type is “VRMat”. This allows the user to set a texture that will be used for the SketchUp material. In this case, you can add the diffuse texture, and V-Ray will not see a discrepancy anymore between the SketchUp material and the VRMat. But this requires manual input.

I’ll investigate if we can automate this by extracting the diffuse from the VRMat (but like mentioned above, this may be tricky if even possible)


#12

Hello Thomas, how are you?

I had already noticed this change in the new versions of V-Ray and this impairs the visualization of the diffuse map in Blend Material as well.

In some materials saved in SketchUp V-Ray does not find the textures for Diffuse and leaves them empty if the texture is only in SketchUp XML.

I create a folder where I save all the textures used in the project so that they are not saved only in the temporary Sketchup folder or in the .SKM material for the V-Ray to recognize.

Maybe we would need to request a solution for the new version of V-Ray Next for SketchUp. What do you think?

Best Regards


#13

I have already asked if it’s possible to disable the binding when loading a VRMat.
But feel free to request a more general solution :wink:


#14

It is actually possible to turn off the binding directly in the VRMat before V-Ray converts it.
So Transmutr will do that in the next version. I tested with your Asphalt VRMat, and it works perfectly! :wink:


#15

Great! This will help us load the materials more quickly. Very cool! :heart_eyes: