Zero Objects Uniform setting bug v1.0.0

Any time I try to use the uniform or grid setting I’m not getting any scattering. Random, vertices and faces are the only modes that work.
Maybe I’m doing it wrong?

Have you tried lowering the “Spacing” values (X and Y)?

Yes, still no scatter.

Tried a fresh install - get this error when I boot up.

C:/ProgramData/SketchUp/SketchUp 2016/SketchUp/Plugins/jbb_skatter.rb:39:in register_extension' C:/ProgramData/SketchUp/SketchUp 2016/SketchUp/Plugins/jbb_skatter.rb:39:in<module:JBB_Skatter>‘
C:/ProgramData/SketchUp/SketchUp 2016/SketchUp/Plugins/jbb_skatter.rb:19:in `<top (required)>’

I run SketchUp 2016 without Skatter, everything starts fine. Add Skatter get this error.

Error: #<ArgumentError: wrong number of arguments (1 for 0)>
c:/users/myusername/appdata/roaming/sketchup/sketchup 2016/sketchup/plugins/octane_render/lib/observers/appobserver.rbs:53:in onUnloadExtension' C:/ProgramData/SketchUp/SketchUp 2016/SketchUp/Plugins/jbb_skatter.rb:39:inregister_extension’
C:/ProgramData/SketchUp/SketchUp 2016/SketchUp/Plugins/jbb_skatter.rb:39:in &lt;module:JBB_Skatter&gt;' C:/ProgramData/SketchUp/SketchUp 2016/SketchUp/Plugins/jbb_skatter.rb:19:in<top (required)>’

There seem to be some sort of conflict with Octane, can you try disable it and restart Sketchup?

I did two tests -

1 - Un-installed Octane from SketchUp2015 - Skatter started, but with same issue of not generating uniform geometry - spacing x / y: 1-10 - as suggested.

2 - Un-installed Skatter from SketchUp2016 - Octane runs as it did before.

It seems the two aren’t playing well together. And that bug for whatever reason remains, and I can’t get the most out of Skatter. Would a video clip show the steps better?

Thanks again.

Ven with very small “Spacing” values, or a way bigger surface?
(In your example, there is not much objects with 40items/unit when using Random, which means you need a very small spacing value when unsing Uniform)

Have you tried in another file?

Okay, we’re good. I wasn’t going ‘small’ enough with the jitter. I guess its all relative to sizing. .01(m?) achieves full scatter.

Still don’t have an answer from Otoy about the conflict, but they’re very tardy on replying.

Thank you for your help Thomas,


I don’t have a license of Octane myself, unfortunately. So I can’t test it.
They never responded to my requests…