[BETA] 1.2.0-beta.4

Version 1.2.0-beta.4

Transmutr is now compiled for MacOS 10.12 and above. We have high hopes that this time the blank window issue on MacOS is finally gone!

Please report any issue in the Bug Reports section . Thanks for your help!

Download Windows: http://files.getskatter.com/transmutr_setup_1.2.0-beta.4.exe
Download MacOS: http://files.getskatter.com/transmutr_setup_1.2.0-beta.4.pkg

Bug fixes

  • Fixed various compatibility issues with MacOS versions older than 10.15.
  • Fixed Transmutr immediately coming back to the file selection screen when loading a model.
  • The scale figure is back.

@Eric_Sargeant @DBJ @jql @AhmedMady @oxer @nrh1981 @HardyV @corey_diru @ThePixelArtist @dimitrisiosifidis @Miki @stefanoc @valerostudiogmail-co @duanekemp @richard-de-ath


macOS 10.13.6 & SU2017

Hi Thomas,

I installed the beta4 and it appears the popup Tramsmutr window now. :+1:

In Trial mode it works fine, I tested to import a obj model format and create Thea proxy and all options work correctly. I’ll continue testing.


thank you

1 Like

Importing fbx format works, the application of textures (bump, diffuse…) on materials works fine and Thea4SU reads them correctly.


Thanks for all your hard work! But it looks like Im still getting nothing on 10.14.6 see attached. Is this supposed to behave like any other plugin: I’ll see it in the Tool Palettes and Extensions drop downs? I have yet to see anything show up. Thanks again!

Oh and I did try to install it in both locations with a re-start with no luck.


When you installed the plugin what option did you select, for All User or For me only?

I had problems with For all user.

1 Like

I did both with no luck. First for this computer then for me only.



Look at this path > /Users/Username/Library/Application Support/SketchUp 2017/SketchUp/Plugins it should have transmutr folder and transmutr.rb file.


Looks like we’ve got something! Im running SU 2019. I have uninstalled SU 2017 & 2018.
But their Application Support files remain and its installing into the 2017 & 2018 folders.
Can I simply drag the 2017 & 2018 Application Support files (SketchUp Plugins) into the trash and try to re install Transmutr? See attached for reference. Thanks!


Or try to copy and paste transmutr folder and transmutr.rb file between 2018 to 2109 plugins folder.

1 Like

Hi @DBJ,

From your screenshot, it seems that the Transmutr files are actually properly installed for SketchUp 2019 so it should be able to detect it under normal circumstances.

Could you try to reinstall SketchUp 2017 or 2018 to check if Transmutr shows up there?

1 Like

That did the trick! I re-installed 2018 and it works there. Now I don’t have any licenses for SU 2018, they’ve all been transferred to 2019 but this is a minor setback for me as I can get a “free trial version” off of CGPersia or somewhere. Im so proud of y’all, big big kisses into the New Year!


Screen Shot 2020-01-15 at 12.14.18 PM

Sketchup 2017
High Sierra 10.13.6

Beta 4
Programme is launching within Sketchup, but giving the following port message. Have tried changing this a few times but the issue persists. Upo clicking ‘ok’ the software appears to be working. Will continue now to test imports and report back. Nice work on the update. :slight_smile:

1 Like

@nrh1981 That’s good news! We’ll investigate why Transmutr has issues with your SketchUp 2019.

Anyone else had such issues with SketchUp 2019?

1 Like

Hey Merwan.
Just to be clear, the ‘port’ error message that I mentioned above comes up with sketchup 2017.

1 Like

@nrh1981 Yeah sorry, I got mixed up between two different issues, I actually wanted to notify @DBJ.

But we’re also still investigating your connection issues!

1 Like

No problem. Oddly enough the software (despite this message) is actually working fine so far. Connection to Bridge was tested as well and the direct link worked really smoothy.
Nice to finally get to test it out.

Loaded SU 2020 to see what Rubys and plugins were ready and was not able to get Transmutr to work, just FYI. I did try to install it both ways user and computer. Still able to use SU2018 to use it. Thanks.

Screen Shot 2020-02-17 at 10.32.22 AM
Screen Shot 2020-02-17 at 11.12.46 AM

It looks like the “transmutr.rb” file is picked up by SketchUp, but that the Extension is not registered. This is really strange.

Can you confirm that there are both a “transmutr.rb” and a “transmutr” folder in ~/Library/Application Support/SketchUp 2020/SketchUp/Plugins/?

Yes for both. See attached User and Computer locations.