Beta 4 - Issue with Mapping

So this has happened on a few different models and I am thinking it is a bug. I have converted some FBX files in Transmutr Standalone and saved them as SKP models. I imported them into another model I was working on, using Enscape as the render engine. Enscape says Invalid Texture for the albedo and only when I edit the roughness parameter for the material, something sets the material texture size in the SketchUp editor to 3’ 3 3/8" and it appears fine and then I have to change that back to 1" in order for the map to go back to the correct size. It’s happened on several models now so I thought I should report it.

Video of the behavior

In Transmutr’s options, is ‘Use absolute paths’ enabled?

Yes. I will give a retry using this option turned off and report back.

I tested with absolute paths disabled and this did not fix the issue with the weird mapping changing scale in Enscape. It might be an Enscape issue honestly. It only happens when I change any of the material parameters in Enscape and then click back into the SketchUp window. The texture scale gets rescaled to 3’ 3 3/8".

Could you send me the original file as well as the skp file right after it’s been generated by Transmutr? (before you open it in SketchUp)

Here are the files

I just tested in the latest installer of the release candidate and the issue persists with Enscape.

Your file works fine on my machine when I run it through Transmutr. The data written in my skp file is identical from your skp file. The only difference being the texture file paths.
I notice that the paths in your file refer to a network drive (R:/), could this be the issue? Maybe Enscape is not able to access the drive or something like that.
Could you try to export the file from Transmutr to your local C:/ drive?

R is a network drive where a lot of our libraries live. I had the same issue appear with local C files on my desktop last week. I do think its an Enscape related issue.

Which version of Enscape are you using?


I tried with Enscape 2.6.1 and still cannot reproduce the issue.

I created a network drive and mapped it to R:\, then created folders "R:\Max\Landscape Misc\Petunia Hanging Basket\" and placed the texture files in there.
When I imported your skp file in SketchUp, the Enscape materials had all their maps assigned and correctly displayed. I didn’t modify your skp file, I imported it as-is.

So it seems that there is an issue with your system or configuration. Maybe some permission stuff.
I’d suggest you reach to the Enscape team, maybe they’ll have a clue.

I sent this stuff over to Enscape to get their thoughts. Thanks Thomas.

Update: Enscape just got back to me after reviewing a file I sent them and they did say it is an Enscape bug.

They advise that it would usually not occur but because you imported the materials instead of creating them in Sketchup; this is the result.

It’s fixable with an adjustment that the developers wanted to work on for 2.7.1, even though that’s more of a feature than a bug. So,it should be fixed in Enscape 2.7.1.

A workaround in the meantime is to check the “explicit transformation” checkbox for the albedo slot before you make any changes. The scaling should then be retained.

Good to know! Thanks for the update