Cannot get connection status: uninitialized constant Lindale::RoomBox::CoreHelper::Core

I’m struggling getting to test this as it won’t load properly (SU2022) and I’m not sure what else to try.
Any ideas?

Load Error Bug Capture 01

Previous version of RoomBox and this one have no internet connection. Transmutr standalone is connecting, SU is connecting. But, RoomBox message says "Cannot get connection status: uninitialized constant
I can’t sign in.
Am I alone in this?

[bug report moved to its own thread]

Hi @duanekemp, thanks for the bug report.
We’re going to investigate your issue.

Several things:

  1. Do you have the latest version of SketchUp 2022 installed?
  2. Could you please send us your log file to [email protected] when you have a moment? (The log file should be located at C:/Users/USERNAME/AppData/Roaming/RoomBoxForSketchup/RoomBoxForSketchup.log)
  3. Which version of Windows are you using?
  4. Could you try installing those Windows packages and see if there’s a difference?
1 Like

Hi Merwan,

SketchUp version installed is 22.0.354
on Win7 Ultimate
Can’t send you the log file because:
Though I have Transmutr, Skatter & SkatterFor SketchUp in the Roaming folder… there is no RoomBoxForSketchUp. INTERESTING?! And why not? :slight_smile:
Will try later the windows packages when I get home tonight.

Anything else I should try? For installation, I downloaded the .rbz and installed it through the extension manager. Is there an alternative method that “should” install a folder in “Roaming” folder

1 Like

Interesting indeed! This confirms that RoomBox is not even able to start, otherwise the first thing it would do would be to create that temporary directory.

Do you use any kind of antivirus software? Some of those aggressively quarantine/delete files if they (wrongly) suspect that they might be dangerous. If so, could you try to temporarily disable the antivirus, reinstall RoomBox (in case some files got deleted) and then start RoomBox again?

Actually just tried the windows packages.
And no… never had antivirus issues before. Will check again to see what “may” be installed but, I have doubts.
Uninstalled the .rbz and reinstalled the first version. Still nothing in the Roaming folder.
Reinstalled the newest version… still nothing.

Checked: Microsoft Security Essentials. Last thing it filtered was march 2021. So, that ain’t it.

Thanks for taking the time to check that out.

It might be related to Windows 7 (to be honest, we haven’t tested it on that platform ourselves) but it should not happen since Skatter and Transmutr seem to work well for you.

Could you tell us which files are stored in:

  • C:/Users/USERNAME/AppData/Roaming/Sketchup/Sketchup 2022/SketchUp/Plugins/roombox/core
  • C:/Users/USERNAME/AppData/Roaming/Sketchup/Sketchup 2022/SketchUp/Plugins/roombox/core/win/ruby_2.7.1
1 Like

Folder - mac
Folder - win


Thank you @duanekemp. Everything looks in order.
We’re going to watch out for other users having this issue in order to gather more hints at what might be causing it.

uhmmmm, … ok.

Hi again @duanekemp

While investigating your issue, I stumbled upon a similar error occurring with the FlexTools extension: LINK

Do you happen to use FlexRooms? If yes, does it work well on your computer?

1 Like

No, never used FlexRooms.

Ok, we’re back to square one.
Still investigating though.

1 Like

Hi @duanekemp

We just released a new beta version of RoomBox.

When you have a moment, could you:

  • install it
  • restart SketchUp
  • open the Ruby console (Extensions > Developer > Ruby console)
  • try to open RoomBox.
  • send us what appears in the Ruby console

The issue will likely still occur but we added a bit of logging to better understand what happens so this might help.

1 Like

Since this last comment, I lost my pc. It was two weeks in the shop and four weeks trying to updgrade to win10, win11 and then, because nothing worked, trying to restore system backup for win7.
I lost a completed client job, several updated files of other work and am still recovering data from the HDD. Sorry for the delay, but, I’ll keep sharing posts on this though I haven’t been able to get down and dirty with it myself. Thanks for the patience.

1 Like

I have similar issue, at first I had tried it on 2018 but realized roombox wont work with that.
The beta was working on 2020 but then i got “a new version is avaialble” ( the official one release ) after which it no longer works, I get a lot of red warnings etc. I’m on win 10 with SU 20.0.363 64 bit.

Transmutr works although the warning “sketchup cannot connect to transmutr…” but this has always been the case.

1 Like


Can you try the following steps?

  • Close SketchUp
  • Delete that file:
    c/users/admin/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/roombox/core/
  • Restart SketchUp and RoomBox

Does the error appear again?

If yes, please try those other steps:

  • Close SketchUp
  • Delete the same file again if it exists
  • Copy
    c/users/admin/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/roombox/core/win/ruby_2.5.1/
    c/users/admin/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/roombox/core/
  • Restart SketchUp and RoomBox

Does that fix the issue?

Thanks Merwan, the first option worked. I wasn’t able to delete the file as it said it was still in use, even though Sketchup was closed ( checked in task manager too), but I think this is a windows issue? I was able to rename the file rather than delete it, (also odd because a rename shouldn’t work either if the file is in use?)


Great news :slight_smile: