Doesnt regenerate or edit the composition after the first time

SketchUp version : 2020
Skatter version (2.0.2_Skatter dialog > Options > About_) :
**Description of the issue : Doesnt let me regenerate or edit the composition after the first time

1 Like

Hi @Pixel_Arquitectura

Can you give us the exact steps to reproduce this? (for instance, “open file > click here > save > …”)

The fist time a do a composition, change settings, etc in render only is fine, then if i want to edit that composition again or change something it didn’t regenerate it just go back to the first settings. it only happens in render only.

Having the exact same problem here, latest update fixed on problem with render only (not appearing in render) but now I can’t edit the compositions once created

1 Like

I have the same problem. So if I generate a composition, I can’t delete or edit objects afterwards. It switches automatically to the original composition. It happens only when in ‘render only’.
If it’s ‘render only’ it doesn’t render the objects as well, only when ‘in model’.
If I turn off the ‘preview’ however, I can edit the composition again. Unfortunately I can’t turn the ‘preview’ back on, it keeps switching ‘preview’ off automatically every time I click on it.

Hi @Pieter_De_Jaegher

Thanks for the feedback.
We fixed this issue for the next update that should be released next week.

It was related to V-Ray. Can you confirm that you’re a V-Ray user?

1 Like

Thanks. Yes vray users

1 Like

Super. Yes, V-ray & SU pro 21

1 Like

Hi @Pixel_Arquitectura @Pieter_De_Jaegher ,

​We just released version 2.0.3 that fixes a few bugs with renderers : [Release] Skatter 2.0.3
Could you check if it solves your issue?

Issue solved, thanks

1 Like

Hi, works perfect now, thanks!

1 Like

hi, it seems I was to fast in my last post… I noticed that some skattered objects don’t render when in ‘render only’ modus. When I change it to ‘in model’ though, it works fine.
Can you take a look at that?

The same problem with me, also sometime doesn’t regenerate if i change in model to render only.

Hi @Pixel_Arquitectura @Pieter_De_Jaegher
Thanks for the bug report.

Have you noticed if this happens for particular objects? Or is it random?

If you have files that exhibit this issue, it would be super helpful for us!


It happens for particular objects, 3d models I get from sketchup 3d warehouse. Where can I get good working plants 3d models that function with Skatter? That would be a great help too :slight_smile:

Hi @Pieter_De_Jaegher

Could you give us links to some of those models? This will help us enhance Render Only mode.

Have you tried 3D Bazaar, the marketplace bundled with Skatter?
It contains a few free models made by us especially for Skatter as well as other purchasable models made by high-quality content creators.