Enscape render issue when render only mode

**SketchUp version :2021

Skatter version (Skatter dialog > Options > About) : 2.0.2
**OS :Win 10
**Description of the issue :Skattered objects are not visible in Enscape V3.2 when render only mode turn on.
Are you able to reproduce the issue every time? (If yes, how?) :
Error in Ruby Console? (Window > Ruby Console) :

Hi @Alex_Dobysh
I’m unable to reproduce the issue.
Could you send us your file? ([email protected])

Actually It is seems to be solved. After creating the composition it’s happening only fist time. When I reopen Enscape window again it is rendering. I tried on this sample file only. I’ll test later in my project file where I first come across this issue.

1 Like

Thanks for the update.

I tested again with the project. It’s weird.
So when the first time load enscape the skattered objects are not visible. It only works after editing the composition and restart enscape again. This is not convenient though. It’s all worked with skater version 1.
Otherwise I need to switch from render only which makes the scene very heavy for enscape.

Ok, we’re investigating this.


We just released version 2.0.3 that fixes a few bugs with renderers.
Could you check if it solves your issue?

Sorry didn’t get back earlier.
Just wanted to do screenshot video however didn’t have a chance yet.
The issue still persists. Moreover when after I’m using zones the results of both rendering when the render only mode turn on/off are looking different in terms of plants quantity and seed.
Could you please review those issues if possible in the next update as the render of multiple scenes in Enscape has become a pain. I can’t do the butch render anymore as I need manually turn the render only mode off for every scene. And the file in this case is slowing down and sometimes crashes because of using the multiple polygons instead of proxies.

Hi @Alex_Dobysh
Could you send us a file that has this issue? I cannot reproduce it.

The issue is actually persists in any new file with skatter v2 and Enscape render.
My Sketchup is 2021.1
Did you try on your file to do the composition render only mode and start Enscape? The objects are not appearing until you don’t start Enscape again or do not switch to in model mode.
And After that when I play with zones the results of rendering of objects within the same composition look different when I switch between render only / in model modes

Skatter 2 Enscape render issue_Optimized.zip (4.0 MB) Hi merwan
Please find attached sketchup scene of file where I reproduce issue. As well as the PDF file of noted screenshots with details. Hope it all makes sense.
Skatter 2 Enscape render issue.skp (3.7 MB)

Thanks a lot for the detailed instructions, that’s super useful!
I’ll try this out asap and keep you updated.

@Alex_Dobysh Thanks again for the detailed instructions. If all bug reports were as detailed, our lives would be easier for sure :wink:

About the bug, I followed the exact steps but it seems to work ok on my side.

However, in some screenshots of you guide, the “Generate” button is bright red (means it has not been clicked since the parameters changed). That would explain why the preview and the rendered output do not match, no?

When changing some parameters, the red preview shows what it will look like after clicking Generate but the render is not updated until you actually click the button.

Does it work after you click generate?

Hi Mewan.
thanks for your response.
It is sad to learn that the issue is on my side. This mean something is happening not depending on Skatter 2. Maybe it is Enscape though. It keeps me puzzled :frowning: It really wield because on Skatter1 all worked well. Have no idea what can cause the problem now.
Regarding to your comment about “generate” button I think maybe I prepared the wrong screenshot.
This issue is also has the same nature as the main one. Enscape is not updating the compositions without either restarting or switching to in model mode

Hi @Alex_Dobysh

Maybe it’s due to Skatter, maybe it’s due to Enscape or a little bit of both. Sometimes it’s just really difficult to reproduce the exact same conditions as users to reproduce a bug, which is frustrating :confused:

You could try to contact the Enscape devs about this issue. It’s actually them who develop the compatibility layer between Enscape and Skatter compatibility layer so they might have more insight than us.