Error when importing composition

**SketchUp version :2021pro
**Skatter version2.03 (Skatter dialog > Options > About) :
**OS :Windows 10
**Description of the issue :When importing the cut grass border composition I get an error
Are you able to reproduce the issue every time? (If yes, how?) :Yes - same error every time I try to import
Error in Ruby Console? (Window > Ruby Console) :

Hi @Jaco_Dippenaar
What is the error?


Thanks for the details @Jaco_Dippenaar
We investigated and fixed the issue for the next update.

Great news Merwan!

Thanks for the promt response!

1 Like

Hi there I am having this issue with both cut grass and cut grass border. I have updated, but still no good? Any ideas? Thanks, Nick

@AMGRY Yes it’s fixed for the next release (2.0.4) that should be ready soon. There’s a few remaining bugs to address and we’ll be able to release it with that fix.

Thanks very much for the reply - much appreciated, Nick

1 Like

@AMGRY The import should be fixed with the latest 2.0.4 version.

Works perfectly, Thanks very much, Cheers, Nick

1 Like

I just noticed that although ‘Computer Render Only Compositions at Startup’ is selected, you still have to Re-generate when you re open a model.


Strange, it seems to generate automatically on my side.

Could you send us those files?

  • “C:\Users\USERNAME\AppData\Roaming\SkatterForSketchUp\options.json.log”
  • “C:\Users\USERNAME\AppData\Roaming\SkatterForSketchUp\SkatterForSketchUp.log”

We’ll try to understand why it doesn’t work for you.

skatter (313.5 KB)

No problem - please find attached,

It may be a case of the ‘older models’ prior to the update are still not working, I tried a test with a new model and it appears to work fine, Cheers, Nick

Thanks @AMGRY, that’s great news.