[Release] Skatter 2.0.4

How to install this update?

You can either:

  • Start Skatter and let it automatically update



Release notes


  • The maximum brush size has been increased to 25 meters. Please note that large brushes might degrade performance when painting over surfaces with dense geometry.
  • Compositions from incompatible versions of Skatter now appear in gray in the Composition Manager and they can be upgraded from there.
  • When upgrading Skatter data coming from older versions, the Upgrade popup now allows users to select individual compositions (previously, all the compositions of the model had to be upgraded without distinction).

Bug fixes

  • Scattered objects: fixed objects being assigned the same color when shift-picking several of them.
  • Paint masks: fixed an error sometimes occurring when erasing part of a mask.
  • Preview: fixed the preview for a composition sometimes disappearing and not reappearing until its editor is closed and opened again.
  • Render Only: fixed referenced materials sometimes being deleted when purging the model.
  • Render Only: fixed disabled compositions sometimes not rendering in V-Ray when toggled back on.
  • Render Only: fixed compositions not appearing if a V-Ray interative render is started before triggering the first generation.
  • Render Only: fixed some assets from 3D Bazaar or Chaos Cosmos not appearing in V-Ray renders.
  • Import composition: fixed an error occurring when picking the composition to import.
  • Convert to composition: fixed an error occuring when converting model entities to a Skatter composition.

sauf erreur de ma part, l’option Render Only ne fonctionne pas avec la toute dernière version de V-Ray 5 Update 2 que je viens d’installer.

Hi @DCHA34
After installing V-Ray 5 Update 2, it seems to work ok on my side.

What’s the exact problem for you?

Lorsque je choisis l’option “render only”, les objets n’apparaissent pas dans le rendu.

@DCHA34 Which objects? Can you share a model that has this issue?

(Please write in english if possible, so that other users that have the same issue can follow :slight_smile: )

It’s a simple cube on a rectangular surface.

I have to close Sketchup and reopen it to make it works.

Hi @DCHA34
For the moment, we cannot reproduce this issue.
Which version of SketchUp are you using? Are you on Windows or Mac?

Sketchup PRO 21.1.332 Windows + V-Ray 5.20.01 + Skatter 2.0.4

Below is a link to the video recording of the problem.

ScreenRecording.rar (1.7 MB)

Thanks for the video!
I cannot reproduce the issue by following the exact same steps unfortunately.

Could you send us your log file (by private forum message or [email protected])? It’s located in C:/Users/USERNAME/AppData/Roaming/SkatterForSketchUp/SkatterForSketchUp.log.

Same problem - skp 2021, vray 5.1 , also 5.2 skatter 2.04 not rendering objects “render only”
I’ve reinstalled skatter, clear library folder and download again, tried 2 versions of vray and none of this worked.
I’ve solved problem by unistalling 2.04 and downgrade to 2.03
link here: [Release] Skatter 2.0.3

Hi @DCHA34 @piotr_buchcic
You can try the latest version: 2.0.5

Hi Merwan,

it works with the latest version 2.0.5.

Thank you for your quick efforts to deploy a patch.

1 Like

Great news!