Mac OSX Port Issue

Hi everyone. Woohoo Mac OSX launch day… excellent stuff. :slight_smile:
We are having a problem getting it to launch within Sketchup, getting a port message.
See attached screenshot. There is no such location as Extensions>Transmutr>Settings.

Any suggestions?

1 Like

I have the same issue. My port is set to 1200.
I have no clue of a better value.

1 Like

I’m guessing the default port is 1200 as this is the same on our end. I have tried changing this to another number but to no avail.
Eager to try this out. :face_with_monocle:

1 Like

Hi @nrh1981 @HardyV, thanks for taking part in this beta.

Here are some ideas to try:

  • If you use an antivirus software or a firewall, the network port that Transmutr uses to communicate with SketchUp could be blocked for security reasons. In that case, you can try to open it (the documentation of such software should describe the steps to do so).

  • Some other applications could already be using this 1200 port. You can experiment with other values to see if it fixes your issue. For instance, try increasing the port number by increment of 1000 a few times (in theory, ports can go as high as 65535).

Please let us know if one of those is successful.

Hi Merwan,
Our firewall is currently disabled, as it interferes with other software - so not that.
Tried changing the port number as you suggest but it doesn’t help. Still receiving the same error message. :frowning:

Oh and just to add we don’t have any active antivirus software running that would block it either.
Changing port no’s casued the program to pause for a while, (presumably whilst it checked the result) but still came back with an error.
(For the record we are running High Sierra 10.13.4 on a 6 Core Xeon Mac Pro w/ Sketchup 2017)

I have the same issue

So this evening i tried installing the beta on my macbook pro. When installing for ‘all users’ i get the same issue as others regarding rb files. Reinstalling the beta as a ‘just me’ install gives me the same port issue as on my Mac Pro.
Still cant get launch the software. :frowning:

1 Like

@nrh1981 @HardyV @AhmedMady
Does Transmutr work correctly when launched as a standalone, outside of SketchUp?

No. My version does not work at all.
White screen.
Nowhere to add license.

1 Like

Does this file exist?
~/Library/Application Support/Transmutr/transmutr.log

If so, please send it to [email protected]

Until now it didn’t work for me
here is a screenshot for what I’m getting when I try to run Transmutr inside SketchUp

another screenshot for what I’m getting when I try to run Transmutr as a standalone, outside of SketchUp.

another screenshot for what’s inside ~/Library/Application Support/Transmutr
Screen Shot 2019-12-17 at 5.19.34 PM

as you can see there is no transmutr.log file there.

In our case nothing launches at all. We are not even getting a white screen.
Our machine is not generating .log file. to send you.

Please try Beta 2: [BETA] 1.2.0-beta.2

If you still have a blank window, please try to give System Permissions to Transmutr, and tell us if it fixes the blank window. Click here to learn how to give System Permissions to a MacOS app.

Giving system permissions to package 2 does not help. I still have a white screen.
And I only see the extension in my SketchUp 2018.
Not in 2019. Though it is listed in my Extension Manager (with no options).

macOS High Sierra 10.13.6 & SketchUp 2017

The 1.2.0-beta.2 installer works fine with “Install for all users” option, it create the transmutr.json file in /Library/Application Support/Transmutr/ but the port issue persists.

Port Issue

I works on macos High Sierra 10.13.6 and there isn’t ‘Full Disk Access’ option in User Preferences with this macos version.

When I launch Transmutr as a standalone it appears nothing, no white window, the bar menu only.

macOS High Sierra 10.13.4 & SketchUp Pro 2017
Hi Thomas,
Installed version 1.2.0-beta2 and the same issues persists. Transmutr won’t launch and I don’t get any screen coming up. I only have the Transmutr menu drops at the top of the desktop but all options are greyed out.
Port issue also remains.
As ‘Oxer’ notes there is no option for System Preferences in High Sierra.

1 Like

I’m using OSX 10.11.6 and have identical issues except that Library App Support is missing the transmutr.json fie. There is no Full Disk Access in this version of the OS and the white screen upon launch is persistent.

I did try turning off firewall, given “Accessibility” in preferences…

What I seem to be missing is the .rbz and transmutr is not showing up in extensions. SU 2019 11.3.236.

I’ll try the new transmutr .2

[BETA] 1.2.0-beta.2:
It did in fact install the extension in SU this time. Upon launch I received the same results as Oxer with message and white screen.

“SketchUp cannot connect to Transmutr. Try changing the Port in Extensions > Transmutr > Settings. If the issue persists, please contact [email protected]

Port is 1200

Hi everyone,

Thanks a lot for your feedback. We have been able to reproduce the blank screen issue in a Virtual Machine (Transmutr works fine on our physical Macbook). We will investigate.

Regarding the “port” message, it is a side effect of the blank screen. It means that SketchUp is not able to communicate with Transmutr, simply because Transmutr doesn’t start correctly.

1 Like