[BETA] 1.2.0-beta.2

Version 1.2.0-beta.2

Among other fixes and changes, this version fixes SketchUp showing an error message at startup on MacOS.
If you still have the blank Transmutr window on MacOS, please try to give System Permissions to Transmutr, and tell us if it fixes the blank window. Click here to learn how to give System Permissions to a MacOS app.

Please report any issue in the Bug Reports section. Thanks for your help!

Download Windows: http://files.getskatter.com/transmutr_setup_1.2.0-beta.2.exe
Download MacOS: http://files.getskatter.com/transmutr_setup_1.2.0-beta.2.pkg


  • Textures embedded in .skp files are now extracted and displayed in the preview.
  • Added a notification when a new beta version becomes available for download.

Bug fixes

  • (MacOS) Fixed SketchUp not finding Transmutr when it has been installed for all the users of the computer.
  • Fixed a crash when entities collections only contained edges
  • Fixed materials with “<” or “>” in their name not loading
  • Fixed not being able to scroll the materials list

@Eric_Sargeant @DBJ @jql @AhmedMady @oxer @nrh1981 @HardyV @corey_diru @ThePixelArtist


I was able to install the 1.2.0-beta.2 for all users successfully and once I run Sketchup I got Transmutr icon in there, but when I hit the icon I’m still getting the same changing the port error message, as you can see in the screenshot that I’ve attached to my reply, I also tried to change the port to different values but that didn’t fix the issue, then I gave System Permissions to Transmutr, but noway, the issue is still there.

1 Like

The same on macos 10.13.6 & SketchUp 2017.

1 Like

Tried to install both ways on this computer vs for me and still get an invalid signature. No toolbar or extension. Again I’m on OSX 10.14.6 on a Mac Pro 4,1 flash to 5,1 running Mojave.
Thanks for the very quick updates and dedication! I appreciate the fact that you’ve all decided to support both OS platforms. I KNOW its twice the work but lets be clear, many of us run both OSX and PC have two computers for work / business / pleasure and have been waiting for an app like this for years. I have both Skimp AND FluidimporterPro and I can say you’re ahead of the curve on this one and being so $upport will follow. Especially with your diligent work, forum support and updates.
I can hear crickets over on some other forums. < thumbs up with smilie face emoji here >

See attached:


1 Like

Hi everyone,

Thanks a lot for your feedback. We have been able to reproduce the blank screen issue in a Virtual Machine (Transmutr works fine on our physical Macbook). We will investigate.

Regarding the “port” message, it is a side effect of the blank screen. It means that SketchUp is not able to communicate with Transmutr, simply because Transmutr doesn’t start correctly.

@DBJ Thanks for your kind words :wink: I’ll try to replicate your signature issue. Thanks for the report.

1 Like

Hi, any news RE getting this working on Mac…? Thx

Hi @richard-de-ath,
The beta is still in progress (just released [BETA] 1.2.0-beta.4 ) and we’re actively working on this.

1 Like