READ-only mode

SketchUp version : V2.
Skatter version (Skatter dialog > Options > About) : 2.1.3
OS : Windows
Description of the issue : Read Only mode. I can not access assets
Are you able to reproduce the issue every time? (If yes, how?) :yes, open 3D Bazaar.
Error in Ruby Console? (Window > Ruby Console) : I don’t know how to do this.

Hi @honeydear

Do you have several instances of SketchUp open at the same time?
This would be why 3D Bazaar is in “read-only mode” (but that doesn’t explain the error)

Could you reinstall 3D bazaar using one of those two methods?

Reinstallation does not work

I tried to restart my computer and only open one sketchup,but Read Only mode always appeared

1 Like

I am having the exact same issue. Im in the middle of projects and not being able to use skatter is creating a major problem.

@xaviervasco It’s very strange that the “Read-only” status persists even after you reboot.

Please try to delete that file and then try again:

If this doesn’t work either, please try to delete the whole folder:


Depuis hier plus d’accès à 3DBazaar, également le même problème “mode lecture seule”.

I’m having the exact same problem as indicated above, with the exact same red error notifications. But on a Mac version with sketchup 2021. How to fix tis?

@Grafit @Jorrit_N

Have you tried this?


Thank you for your reply. It works now.

Thank you so much.

1 Like

Hi, thanks for the reply but I use a Mac, so there is no C directory. Do you have a Mac-specific solution? I can’t find the ‘appdata’ or ‘roaming’ folder. Thank you

On MacOS, this might be located in /Users/Username/Library/Application Support/SketchUp 2017/SketchUp/Plugins

Hi Merwan, the strange thing is, there is no such folder on my Mac… Any other suggestions on how to fix the issue?

That’s interesting. Do you have this folder?
/Library/Application Support/SketchUp 2017/SketchUp/Plugins

(looks similar but it’s not in the Users folder)

Hi Merwan, yes i have this folder, although with SketchUp2021.
Within the subfolder ‘plugins’ there is no file related to Skatter or 3DBazaar. However, the plugins are installed though.

Thanks for the screenshots.

That’s unusual because SketchUp extensions can only be installed in those two locations on a Mac:

  1. /Users/YOUR USERNAME/Library/Application Support/SKETCHUP VERSION/SketchUp/Plugins
  2. /Library/Application Support/SKETCHUP VERSION/SketchUp/Plugins

If the plugins appear in SketchUp, this indicates that the 3D Bazaar files should be there.

Can you confirm that they’re not in location 1 with a screenshot like you did for location 2? Thanks

Hi Merwan, thanks for the reply. The files aren’t in the other folder you suggest. It is very weird…! See the screenshot attached. So the plugin is installed and visible in Sketchup, but no files can be found in the folder. I also checked the App files and the plugin folder there, but no files either.

Hi @Jorrit_N
Sorry for the delayed response, I had to do some tests.

All of that is very strange indeed. 3D Bazaar, which is a separate extension bundled with Skatter, should be installed automatically the first time that you try to start it but this part doesn’t work on your computer. it’s unclear why.

Could you try to install the latest version of Skatter ( and try to then start 3D Bazaar again to see if there’s a difference?
I’m not sure this will fix the issue but at least this will rule out a bug in an older version of Skatter.

Hi Merwan,
No worries, I really appreciate your time and effort in this! I tried to install the latest version and restarted but unfortunately no difference. It keeps on showing the red waring messages when starting 3D bazaar. Skatter works properly though. I also tried to restart Sketchup but that makes no difference. I’ve checked the Application Support folders again but no files, neither from Skatter or 3D Bazaar are in there.
I even tried to install it from a new user account on my computer, just to experiment / check, but also no success with that.

Hi Merwan, I think I found the issue. Apparently, in the Application Support folder there were (quite some) subfolders hidden ( not visible in Finder)… I managed to unhide them and deleted the 3Dbazaar lock files etc. It seems to work now. Why these folders were hidden… I don’t know…

1 Like