SU locking up after Skatter generate

SU 2020 (Current)
Skatter 1.4.12
Win 10 Pro (up to date)

Trying my first big project with Skatter on a large residential development project with several ponds/wetland regions. Hoping to scatter some tall grass around these wetland areas (along with several other plant layers), but after setting up just a couple areas SU has started to lock up and not respond,usually right after I hit the Generate button. It typically will show the preview ok and will generate the scatter, but will then lock up SU with no option but to end the SU process in the task manager.

Here’s a WIP gallery for the project to give you a better idea.

Fyi, the first pond area was doing ok (approx 15k grass scatters, plus some water lilies and some prelim street trees). It’s when I get to the next larger set of ponds (ponds 2 and 3 of 8) that things started to crash. Those had about 75k scatter objects.

Anyhow, really stuck here and could really some help or input. Thanks!

P.S. A few other weird issues and possible bugs I thought I’d mention. When I open the Skatter dialog and go to edit a setup, I keep getting “You have pending changes that were not generated, are you sure you want to close the Skatter dialog?” and then, after hitting “no”, the Hosts and Scattered Objects lists will usually show duplicates of everything.

Also, Skatter seems to be deleting my layer (tags I mean… such a stupid new name)! I’ve put my setups in there own layers/tags under the render list, only to later find them cleared (blank) again and the layers/tags completely gone!

Finally there’s be several times while trying to add host objects or scattered objects that Skatter gets buggy and the select buttons/icons will stop working. Have to close/restart Skatter and reedit the setup to get it to work again.

I know V2 is getting close to beta, so maybe none of this really matter, but I thought I’d still mention it.

1 Like

Are you using “Render Only”, or are you generating in the model?

Yeah, I certainly am.

I’m also starting to wonder if it’s not actually a SU 2020 bug. I’ve had SU lock up in a similar way a couple time now while doing other stuff and not actively using the Skatter plugin. But the problems did seem to start after I adding Skatter objects to the scene… so not sure which is the true culprit!

1 Like

Is this happening in every file? Or only that big project?

1 Like

Hi Thomas, sorry for the late reply. Not sure yet if this is happening in other files as this is actually the first real file/project I’m using Skatter on. But I have tested Skatter a few times, here and there, and this is the first time seeing this issue, so it might just be with this file/project.

Again, I’m not 100% sure if this is a Skatter or SU issues as I have had SU lockup and “Not Responding” several times doing other things. Those time SU did finally come back after 10-15mins. But it’s happening the most while using Skatter and after hitting “Generate”. It also doesn’t happen every time I hit generate, which makes it even more tricky. But it does almost every time I try to generate a lot of objects on a large terrain area. (ie 40k plus objects, etc)

Fyi, just a side note, I also just upgraded my machine here for this project, so a lot of variables have changed since previous project and these issues. Before I was running Win 7 Pro with Sketchup 2017 and a GTX 770. I’ve now upgraded to Win 10 Pro, SU2020, and added a Titan RTX.

1 Like

Do you have Enscape running when this happens?

Yeah, I finally figured out it yesterday that it only seemed to happen while Enscape was running. Sorry, forgot to post an update to this issue.

I was obviously able to finish the project once I figured that out. Just needed to close Enscape before making or changing any Skatter setups. It was unfortunately kind of a pain as it took Enscape 4-5 to load up that scene each time afterwards.

So I’m not sure if it’s an issue with Enscape or Skatter, or just a bug between the two. What’s your thoughts?

What’s interesting, whenever it would lock up, while Enscape was running, the Skatter setup would generate fine in the SU viewport and also update in the Enscape window as well, only then to become unresponsive like it’s still trying to process something. In task manager the SU process is still running at about 12% (one core at 100% probably) while it’s unresponsive. Anyhow, just FYI.

1 Like

Just did another test with a new scene and was able to reproduce the “Not Responding” issue between Skatter and Enscape.

It definitely seems to only happen after you generate a skatter setup with the Enscape viewport running. The skatter will generate in SU and update fine in the Enscape viewport, but then sketchup will become unresponsive. It doesn’t happen everytime, but does once the object scatter count gets high enough. At around 5000 objects it did respond again after about 5 minutes. But with a bigger I did with 87K object it was still unresponsive even after 30mins. (see attached screenshot).

Interestingly, the Enscape viewport is still active and functional, only sketchup is unresponsive.

1 Like

Thanks, I was able to reproduce the issue!

It looks like Enscape is struggling to update its geometry when the Skatter data is updated. We can’t really blame it considering the sheer amount of geometry.
But the weird thing is that the freeze happens just after the Skatter setup is updated in the Enscape window.

I will reach out to the Enscape developers to report this issue.


the same is happening for me, are there any updates on the conflict with running enscape and skatter? that’s basically the main combination i was looking for, using skatter with enscape. but closing enscape everytime i want to generate a skatter group or edit on is a bit of a bummer :frowning:

We think we know why this may happen, although we haven’t had time to try to implement a workaround.
I’ll try to do it soon.

​Hi guys,

I think I fixed the issue with SketchUp freezing when changing settings in Skatter while Enscape is running.
Can you try this version of Skatter and tell me if it fixes the issue?


@Merlin_Bartholomaeus @ThePixelArtist

hey @Thomas. i was only on your skatter-trial while i encountered the error and kept holding back to buy because of the issue. unfortunately can’t try it but it’s great to hear that you worked on a solution!! eager to find out if it’s fixed :slight_smile:

Hey Thomas, yeah, no problem. I’ll check it out.

You can get more demo time by going to the “Extensions” menu, then “Skatter > Deactivate License”. This will delete your license file and then you can activate the Demo again. This is a one time thing to get extra 15 days.

P.S. That link isn’t working. Is it still uploading maybe?

P.S.S. Nevermind, got it to work. Had to remove this last part (%E2%80%8B) from the link.

P.S.S.S. (lol) Ok, one more thing. That exe is getting blocked by Windows 10 Defender and won’t let you install it unless you manually go in and unblock it in it’s file properties. Just FYI.

1 Like

Oh? That’s not good.
I’ll look into it, thanks for the report

Gave 1.4.18 a test this morning, along with Enscape 2.9, and it seemed to work great.

Started out by reopening this scene Neighborhood Wetlands (Skatter V1, Enscape 2.8 beta w/ RTX, PS)

Unfortunately this scene is still a real problem, performance-wise, for Enscape and it seems likes it’s only gotten worse with the new releases (again, with a Titan RTX :confused: ). The scene was still somewhat controllable with, I think, Enscape 2.7 (or 2.6), but I can barely move the viewport with all the Skatter objects on. That said, it does work and I was able to open one of the main grass group comps and edit it a bit. Every click and variable change takes a few seconds to re-respond before you can do something else. Tried to re-generate the comp a couple times and the Enscape didn’t seem to lock up at least, but it also wouldn’t update with the new changes. Again a couple more tries my whole computer locked up and I had to hard shut it down and let it cool off for a while. Guessing my card maybe overheated. So, I don’t think this is a Skatter problem but an Enscape issue. It’s just not very good with lots of instances and I’m not planning to use Enscape for large projects anymore (probably move to Vray 5 or Lumion)

Anyhow, did a second test with a brand new scene and Skatter seemed to work really well. Didn’t have any issues with it freezing SU or Enscape. Started with a medium size set of Skatter comps, then increased the surface size by 9 times (300+k instances for the biggest group) and it still generated without issue or freezing things. It does take about 20-30+ seconds to fully show that big group, the first time, in Enscape, but it’s kind of cool as it updates progressively (each plant in the set at a time, 6 total ). Subsequent chance are faster to update though.

Only small issue is that after editing one Skatter comp then going to edit another comp I always get the “You have pending changes…” dialog box everytime, even though I just generated the previous one. I don’t understand that one.

Here’s some screenshots of this test scene.

1 Like

Thanks for the confirmation!

I’m not really surprised that Enscape struggles with really large projects. As a real-time engine, it’s not really meant to deal with huge datasets.
Maybe you could try to create larger patches of plants. Instead of scattering individual plants, try to scatter groups of plants. This will lower the amount of data Enscape has to process.
Also if you have Transmutr, you could try to simplify the geometry a bit.

thanks thomas, i just read this. unfortunately sketchup / skatter freezes when i want to reactivate the demo liscense ^^