V-ray renders empty scene with Skatter

SketchUp version : 2020 Pro
Skatter version 1.4.15 (Skatter dialog > Options > About) :
OS : Windows 10 64-bit
Description of the issue : V-Ray (4.20.03) renders empty scene when any setup is generated by Skatter. V-ray renders correctly only with very limited number of skatter objects (i.e. 200). Before V-ray and Skatter update everything was just fine, and I was able to render hundreds of thousands skatter objects.
Are you able to reproduce the issue every time? (If yes, how?) : Yes, it happens every time when render.
Error in Ruby Console? (Window > Ruby Console) : Only error in V-ray progress window "[AppSDK:fillSettingsVFB] Can’t modify renderer while asynchronously preparing to start rendering.

Can you try to roll back to V-Ray 4.20.02?

More info here: Major issue with V-Ray Next Update 2.2 (4.20.03)

I’ve tried it, but it didn’t work. The issue in V-Ray 4.20.02 is exactly the same.

Before sketchup update I was working with some older v-ray version (around 4.00.00) and skatter worked fine. But now I cannot go back behind V-ray 4.10.03., because I cannot roll back to sketchup 2019, which license was updated.

Wolny od wirusów. www.avast.com

Ok so this must be another issue.

When you create the Skatter setups, do you see the red boxes preview?

Yes, everything generates correctly in preview. Only rendering fails.

Wolny od wirusów. www.avast.com

Does this happen in a brand new file, when scattering a simple cube on a simple plane?

If not, could you send me a faulty file?

It happens when I try to render grass components on a plane component. This is my basic file with grass setup, I was using it on a daily basis until update.
Skp model and 2 render (successful with 200 objects and unsuccessful with 18000 objects): https://we.tl/t-DoyzlHgNl6

Wolny od wirusów. www.avast.com

Thanks for the files.
I’m not able to reproduce the issue, but the render does take ages to start. Maybe your system runs out of RAM or something like that?

I noticed the grass patches you are trying to scatter are really heavy, they have a lot of faces. I converted them to V-Ray proxies, and then the render was much faster to start. Maybe you can try that?