Vray - sketchup 2021

When i try to do a composition in skatter with a v-ray scene or proxy when I put the option render only it doesn’t render the composition, if i put in model it render the composition but theres too much geometry in the model.

Help please

**SketchUp version : 2021
Skatter version ( Skatter composition) :
OS :
**Description of the issue :doesn’t work render only with proxies or vray scene

Hi @Pixel_Arquitectura
Please send us a model that has this issue and we’ll investigate.

hi, this an example. It happens with every vray scene I imported to the model that y want to skatter.

In render only:

In model:

That’s the issue, when i tried to render any proxy or vrscene that i imported to the model and i skatter, they only render in model mode.


Can you send us the file?

We have a few users who have this issue with V-Ray (seems to often be related to Chaos Cosmos assets) so we’re still investigating.

For sure this is the link where you can download it.

When you solve it, please let me know.


1 Like

Same problem as above :point_up_2:

**Sketchup Version 2020
** V-ray 5
** Skatter V2 (I did not notice the problem in Skatter V1)

I have exactly the same issue.
-sketchup 2021, vray 5, skatter 2.

For example when I want to skatter any group created with another groups inside, or group of proxies, or just vray-scene in render-only mode - the elements don’t appear.

@Pixel_Arquitectura Thanks for the files.

@kwadri @marcinn Could you also send example files please? The more examples we have, the more likely it is for us to understand the issue)

Thanks for reply @merwan

Also I noticed that when I import vrscene I can scale it easily and vray renders correctly.

But when I press the generate button the imported vrscene goes back to the size it was before scaling,
and the generated (render only) does not appear.

When I try generated (In Model) the results vary sometimes is
problem with the scale of imported vrscene file.

and sometimes not.

hope the pictures show the problem well.

In the link below you will find the example files:

When you solve it, please let me know as quickly as possible.

One more problem…
I’m not sure it’s a problem with Skatter or 3D Bazaar.
When I import saved asset from my local library in 3D Bazaar strange things are happening.

Render Only mode: Render shows an object(tree) that does not exist.
But this object(tree) was in this place when I exported file with skatter composition manager.
In my opinion it should not be visible

In model mode: render no longer shows object(tree) at the axes origin point.
and is no problem with generated objects(trees).

I hope I managed to explain it well :sweat_smile:

Thanks for the details. We’re actively working on this bug.

Quick update: rendering issues with some objects have been fixed. It was indeed related to nesting. Thanks for the tip :slight_smile:

We’re now going to investigate the vrscene scaling issue.

Hopefully the upcoming 2.1.1 update will contain most of these fixes.

1 Like

Great news!
Thanks a lot!

1 Like

We just released version 2.1.1 that contains a few V-Ray bug fixes [Release] Skatter 2.1.1
(still investigating the vrscene scaling issue)

Hi, actually I just upgrade to skatter 2.1.1 and still doesn’t working the render only with vray scene components. :frowning:

Please check that!!


Could you send the vrscene file to [email protected]?

1 Like

I have send you right now to [email protected] please check it. My email is [email protected]

1 Like

Unfortunately I can’t update.

Exactly the same problem as the g2021 user mentioned in the [Update From 2.1.0 to 2.1.1] topic.

There was an error in the update sent by our server, it was actually the previous version ( Update From 2.1.0 to 2.1.1 - #4 by merwan )

Please try again.

After upgrade to skatter 2.1.1 The render only mode with vray scene components still doesn’t works.